Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

VMware Solutions Discussions

SMVI 2.0.1 P1 for vCenter

dailyfresh

Hello,

I've got a question in relation to SMVI for vCenter.

 

In CLI "smvi version":

SnapManager for Virtual Infrastructure CLI 3.0.1P1 (build date='101207_1945', version='1208')
SnapManager for Virtual Infrastructure Server 3.0.1P1 (build date='101207_1945', version='1208')
 
The problem is that I can't create backups from within vCenter. I can add a schedule, see all devices but when I run the job I get the following error:
Job failed: Did nt find any of the following datastores or virtual machines to backup: []. Storage system(s) need te be added.
 
When I type in CLI "smvi discover datastores", the result is:
[15:11] [ERROR] No storage system defined for target "iqn.1992-08.com.netapp:filera" used by datastore vmfs op filera (4c86aedf-b607823d-b573-78e7d1dfe99e)
[15:11] [ERROR] No storage system defined for target "iqn.1992-08.com.netapp:filerb" used by datastore vmswap op filerb (4c86af61-4672f875-97ba-78e7d1dfe99e)
[15:11] [ERROR] Unable to manage datastore datastore-15: No storage system defined for target "iqn.1992-08.com.netapp:filera" used by datastore vmfs2 op filera (4cfcf198-67b599a0-40fa-78e7d1dfe99e)
 
Everything else works fine. I not a expert user. I can't find a place in vCenter to configure or check datastore configuration. Within vCenter, NetApp tab, "Storage Details -SAN" just gives the right volumes, lun pathnemes, etc.
 
Does anyone uses the plugin SMVI for vCenter and can give a little guidence?
 
 
Regards.
7 REPLIES 7

kkaushal2

I had similar issue, with my storage properly configured in SMVI.

SMVI was failing with the below error:

ERROR - Did not find any of the following datastores or virtual machines to  backup: [4d9e23f0-9ba5832c-d9d8-00145e7aa3fe]
2011-04-18 11:20:08,336 ERROR  - FLOW-11019: Failure in VmGetVirtualMachinesToBackup: Did not find any of the  following datastores or virtual machines to backup:  [4d9e23f0-9ba5832c-d9d8-00145e7aa3fe]
2011-04-18 11:20:08,336 ERROR -  FLOW-11010: Operation transitioning to abort due to prior failure.

The issue was resolved after runing rescan for storage on ESX HBA adapters.

merci

I had the same issue "Did not find any of the following datastores or virtual machines to backup..."

Doing a rescan from the ESX iSCSI configuration fixed the problem.

jessetscott

Where can I download SMVI 2.0.1 P1?  We are currently running SMVI 2.0, and I cannot find 2.0.1 P1 in the software section of NetApp Now.

Thanks,

J

dailyfresh

It already was available for download last December. Steps as mentioned on the NetApp® Virtual Storage Console 2.0.1 for VMware® vSphere™ Download Page:

  1. Go to the NetApp Support Software Download page at http://now.netapp.com/NOW/cgi-bin/software/.
  2. Scroll down to the drop-down list labeled “To access a specific” and select “Virtual Storage Console for VMware vSphere.”
  3. Enter version “2.0.1P1” and click “GO.”
  4. Download the appropriate VSC 2.0.1P1 32-bit or x64 files.
  5. After the download is complete, install the Virtual Storage Console software by following the steps in the NetApp Virtual Storage Console 2.0.1 for VMware vSphere Installation and Administration Guide (HTML, PDF).

vmsjaak13

It's not SMVI 2.0.1 P1, but VSC 2.0.1P1 (Virtual Storage Console, a vCenter plugin).

Check out the download page on NOW.

The 2.0.1P1 verson can be downloaded, if you follow the instructions here: https://now.netapp.com/NOW/download/software/vsc_win/2.0.1/download.shtml

Regards,

Niek

amritad

Hi

Just to double check. In the home view of the plug-inà set-up tab have you added your NetApp Storage systems which host your datastores?

Regards

Amrita

dailyfresh

Hello Amritad,

Thank you for the quick response! No, this one I overlooked. Stupid me. This was de one option I was looking for. I added our filer and tried the backup job again. They did run this time and with succes!

Thank you for guiding me in the right direction!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public