VMware Solutions Discussions

SMVI Restore agent SFR fails to mount disk

belgianbiscuit

hi guys,

I am trying to do a SFR. Although it worked fine when I tried it first I cannot get it to go anymore.
I have a backup of a datastore. This datastore contains a VM to which I want to restore a file.

I enter my source and destination to be the same VM and I specified limited SS and Selfservice on different occassions.
I clear my config, load the new one and select my VM.

I mount my backup and I get error that it failed to mount disk <> in backup <>. It says there was error mounting on the ESX server.
I cannot see anything in my vsphere client.

However, I can mount the same backup just fine by going into restore\backup\mount.

Any ideas?

10 REPLIES 10

amritad

Hi

Can you check these?

- RA only supports the first partition on a virtual disk. For other partitions, you have to manually

use the Disk Management or diskpart tool.

- RA only supports NTFS/FAT-formatted partitions on a disk.

- SMVI can't add new SCSI controllers to power on a destination VM. Therefore the number of

disks that can be attached to a VM are restricted by the available free slots on existing SCSI

controllers. A VM can have a maximum of 60 disks (15 slots on 4 SCSI controllers).

- The automount feature is by default enabled for Windows XP and Vista. Therefore on VMs

running these operating

Regards

Amrita

Firewall1976

I am having the same issue as this guy. My VM's adhere the to RA rules you have stated.

Do you have any further advice?

In my case, it turned out a permission thing. I had changed the permissions in vcenter

amritad

Good point. I'll add that to the list too

REgards

Amrita

ekashpureff

Ms Das -

I've been enjoying tr3737 again today !

( http://media.netapp.com/documents/tr-3737.pdf )

Thought you'd like to know your work is appreciated.

: )


I hope this response has been helpful to you.

At your service,


Eugene E. Kashpureff
ekashp@kashpureff.org
Fastlane NetApp Instructor and Independent Consultant
http://www.fastlaneus.com/ http://www.linkedin.com/in/eugenekashpureff

amritad

Thanks Eugene. Let me know what I can change to make it more helpful. We are working on the TR 3737 update for VSC 2.0 so all feedback is welcome J

Regards

Amrita

Firewall1976

Quick update guys, the error was on my part.

I never realised you had to run the RA on the actual server you were wanting to do the restore to. I was running it from my PC. No the wonder it couldn't mount the backed up disks 😉

amritad

Good to know J.

You could create a VM for SFR, install restore agent on it permanently and re-use that for multiple SFR operations.

Regards

Amrita

belgianbiscuit

Are you saying RA does not have to be on the destination VM as stated in Best Practices guide?

amritad

No Ra has to be on the destination VM. I was just suggesting that you could permanently assign 1 VM as a destination VM by installing RA on it. IT’s not a best practice or anything I was just recommending it sine then you do not have to install RA again and again on different VMs.

Regards

Amrita

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public