VMware Solutions Discussions

SRA 3.0 install error

Hi,

 

Install of Netapp SRA 3.0 fails with a warning that part of the install did not return an expexted result. The windows event log show the following error:

 

Product: NetApp Storage Replication Adapter 3.0 -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action PerlFile, location: E:\Program Files\VMware\VMware vCenter Site Recovery Manager\external\perl\bin\perl.exe, command: "E:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\CMODE_ONTAP\command.pl" -I vpserver *************

 

 

I have omited the password with *********

 

The SRA is not available at this point. Has anyone had this issue? Any idea of a fix?

 

Thanks

 

 

 

18 REPLIES 18

Re: SRA 3.0 install error

Had same Problem and fixed it by starting the installpackage from an elevated command prompt.

Re: SRA 3.0 install error

Thanks that got passed that issue. I know get the following in vCenter.

 

Failed to load SRA from 'E:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\CMODE_ONTAP'.

Cause:
SRA command 'queryInfo' failed.

Cause:
Internal error: proxy: transport protocol not specified

 

 

 

 

 

Any ideas welcome?

 

Thanks

Cliff

Re: SRA 3.0 install error

Yes you are right... have the same issue. I will open a Case and let you know...

 

BR Peter

Re: SRA 3.0 install error

Got a call from Netapp and they informed me that SRA 3.0 is not supported in my configuration CDOT 8.3.2 and so they couldn't help me. I recommend you to open a case.

 

BR Peter

Re: SRA 3.0 install error

I have also opened up a case with NetApp and they routed the case to the Virtualization department to start to help with the testing. Its weird since On my production site I am able to see the SRA installed which is Server 2008 R2 but my DR site it us unable to detect it and that is running server 2012 R2. Maybe that has something to do with it?

Re: SRA 3.0 install error

For me it worked not on Prod or DR Side. Both Sides are W2k12R2, so thats a possible reason. I am looking forward to hear about they get it fixed for you.

Re: SRA 3.0 install error

Has anyone else gotten something from NetApp support on this?  I am facing the same issue.

Re: SRA 3.0 install error

I ran into the same issue, I opened a ticket but by the time anyone got back to me I fixed this issue myself.  Whomever writes thier code does a horrible job of creating items.  If you're still intrested in the solution feel free to send me an email dror at dror dot us. 

Re: SRA 3.0 install error

Same error here. 

 

Windows 2012 R2.

Re: SRA 3.0 install error

Well, FML.

 

Messed around with this for ages and finally figured it out -- the NetApp SRA 3.0 uses hard-coded path names in command.pl, so if you haven't installed SRM in the default location (C:\Program Files\VMware\VMware vCenter Site Recovery Manager\), you're going to have a bad time

 

In my case I have SRM installed into D:\Program Files\VMware\VMware vCenter Site Recovery Manager\

 

 

I fixed this by the following commands from and admin command prompt:

 

c:

cd \Program Files\

mkdir VMware

cd VMware

mklink /j "VMware vCenter Site Recovery Manager" "D:\Program Files\VMware\VMware vCenter Site Recovery Manager"

 

Restarted the SRM service and now I can see the SRAs.

 

 

Check this out:

 

$ nl command.pl |grep -C2 'C:'
   202                            KeepRoot      => 1);
   203  my $incoming_XML = eval { $xml->XMLin('-') }; # read XML input data from STDIN
   204  #my $incoming_XML = eval { $xml->XMLin('C:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\CMODE_ONTAP\input.xml') };   # Presently we are are using dummy file input.xml
   205  my $workingxml = $xml->XMLout($incoming_XML);# Extracting xml and putting it in a vraiable so that it can begave as string .Incoming xml from SRM  is stored in workingxml for future use
   206
   207  my $vp_credential_XML= eval { $xml->XMLin('C:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\CMODE_ONTAP\sra_config_properties.xml') };    # read sra_config_properties XML
   208  #print Dumper($vp_credential_XML);
   209
--
   404
   405                          # writing XML for the latest command to the file path below for debugging
   406              open(SRAOUTPUT,'>>C:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\CMODE_ONTAP\output.xml');
   407              print SRAOUTPUT \$outputfile."\n";
   408              print SRAOUTPUT  $XML_DECLARATION;
--
   412                  #to show each tag in new line we are calling xmlin and xmlout once again ,we can ignore it and write the xml directlyy in $outputFile
   413
   414                  #my $sra_response_xml = $xml->XMLin('C:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\CMODE_ONTAP\output.xml');
   415                  #my $xmlOutput = eval {
   416                  #$xml->XMLout($sra_response_xml,

 

Re: SRA 3.0 install error

This is a possibillity as on my installation I also tried to install on D instead on Default C. In the meanwhile I have installed Version 2.1 as Igot no support from Netapp as SRA 3.0 is not supported for my CDOT Version.

 

Which Programming Beginner has hardcoded Pathes into a Script?

 

Anyone Else here who can confirm that this seems to be an issue with Installations in non default Pathes?

 

BR Peter

Re: SRA 3.0 install error

I can confirm that SRA 3.0 won't work on a non-standard install path.  After 2 weeks of waiting, someone at NetApp was able to get me an answer.  I even escalated the case through our account team, just to get an answer.

 

I also found an error where the config file SRA 3 uses to talk to the VASA provider doesn't get written correctly and introduces a space between the host name and the colon and port specification.  Manually editing the file cleans that error up.

 

Total garbage, in my opinion.  Hard coded paths should simply not be an issue.

 

Still evaluating if it actually works.  I'm seeing some other odd things related to SnapMirrored volumes I need to sort out.

Re: SRA 3.0 install error

Had the same issue. Turns out that paths to certain input/output files are hard coded in the commands.pl script file and as I didn't have SRM installed in the default place on the C:\ drive this was causing the 'proxy: transport protocol...' error. A find/replace from 'C:\' to 'D:\' in the commands.pl script file under the <SRM Install location>\storage\sra\CMODE_ONTAP folder was enough to get it working properly. 

 

I'm guessing this will work for you also but might need to edit the paths a bit more than just swapping drive letters.

 

Re: SRA 3.0 install error

Since I've had a few people email me about this I guess this is more common than not.  My solution to this is:

 

When the SRA installs unless you take the default settings to install the application to the C drive it hard codes a file to that path regardless if you change the path during installation (which is odd since they give you the option of changing the path you would think this would work).  I ended up tracking down the command.pl file found in.  My data path is located on the E: drive not C: 

 

e:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\CMODE_ONTAP

 

i would back up the original file command.pl just to be on the safe side.

 

When you open the file search for the below:

 

original: my $vp_credential_XML= eval { $xml->XMLin('C:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\CMODE_ONTAP\sra_config_properties.xml') };    # read sra_config_properties XML 

 

modified: my $vp_credential_XML= eval { $xml->XMLin('e:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\CMODE_ONTAP\sra_config_properties.xml') };    # read sra_config_properties XML 

 

original: open(SRAOUTPUT,'>>C:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\CMODE_ONTAP\output.xml');

 

modified: open(SRAOUTPUT,'>>e:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\CMODE_ONTAP\output.xml');

 

Once I fixed those it fixed all my issues with the SRA piece of it.

Re: SRA 3.0 install error

Anyone able get get SRA 3.0 working with cDOT 8.3.2 & AFF8000 series?  Error message I receive "SRA command 'discoverDevices' failed. No SnapMirror relationship found."  I have also tyried SRA 2.1P1 per NetApp Support, but that didn't work either.  Still working with Support, but have not made much progress yet.  SRA 3.0  does works fine with my AFF255X series controllers though.  VASA seems to be working correctlyt as this is now required. 

Cloud Volumes ONTAP
Review Banner
All Community Forums
Public