The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

VMware Solutions Discussions

SRM fail back failed

sethbiggi

I am testing vmware SRM and was able to fail over to the DR site. I tried to failback and it failed.

The way it is sitting now is the VM is running at the DR site, and everything was reversed on the protection plan.

Trying to do a recovery and it fails with "Error - Failed to sync data on replica device '/vol/DDC_TestDev_SRM/DDC_TestDev_SRM'. Device found is neither of the SAN type nor of the NAS type. Ensure that the device exists on the storage array and is of type NAS or SAN."

When I look at the snapmirror.conf on the DR netapp, I do not see any entry for this, but in on command under SnapMirror it is listed and the trasfer status is "ok"

Any help is appreciated!

-Seth

9 REPLIES 9

pflecha

In SRM under Array Managers\Devices does it show the snap mirror blue arrow pointing to the Protected site?  Are you able to do a snapmirror update?

sethbiggi

Yes to both It shows that in SRM and in snapmirror I can update.

pflecha

And this is a recovery, not a test right?  Did you generate the VMware Site Recovery Manger Log Bundle?  SAN or NFS?

If iSCSI, go under Host and Clusters\ESXi host\Configuration\Storage Adapters and verify you have a mounted iSCSI adapter.

sethbiggi

Yes I am doing a recovery.

I have generated the log bundle

SAN

pflecha

If you look on the DR Storage Array, do you actually see the device?  That is a common error listed on the SRA IAG and the corrective action is to "Ensure that the device exists on the storage array and is of type NAS or SAN." 

sethbiggi

The lun is listed there

 

DDC_TestDev_SRM

 

/vol/DDC_TestDev_SRM_SnapMirror_01032013_112955

pflecha

Did you try doing a test?  For a test failover SRA will create a new igroup, that will be removed during a test failover cleanup.

sethbiggi

I didnt actually run the test.

So now I ran the test and the test worked.

Retried the recovery, and it worked.

Is testing of the recovery plan required?

pflecha

Definitely not.  As a matter of fact the testing workflow requires a FlexClone license but the other workflows (Recovery\Reprotect) do not  I am thinking there may have been an issue with the igroup you were using.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public