The community will be undergoing maintenance soon, requiring Read-Only mode. Click to learn more.

VMware Solutions Discussions

Trouble using HA Configuration Checker (ha-config-check.cgi) 2.0

MADISONDIOCESE

Hello,

I have a dual-controller FAS2040 and I'm trying to check my HA configuration. I'm having trouble using the HA Configuration Checker utility. I'm running through CLI on Windows. These are the commands I use to run the Configuration Checker:

C:\ha-config-check.exe -l <IPaddressFirstNode> <IPaddressSecondNode>

I have rsh enable on both controllers. And I get the following error when running the configuration checker:

'rsh' is not recognized as an internal or external command, operable program or batch file.

Cannot rsh into <IPaddressFristNode>

I've also tried with ssh but no luck either, I get the same error but with ssh instead of rsh.

Can you please help? Is there some configuration I'm missing?

Thanks!!

4 REPLIES 4

martin_fisher

Hi - Just a quick thought, is the Windows Server a 2008 server? - if it is, make sure RSH has been installed, as it is not installed by default in 2008.

the HA ClusterConfig Checker.exe relies on this heavily.

Do you have DFM Operations Manager? - This has a Cluster Config Checker feature in later version.

Alternatively download and use plink.exe to create a batch file which should be able to invoke the .exe and run it against the NetApp filer.

Martin

No, it's a Windows 7 Professional machine. I will check if I have RSH installed on my computer.

What is DFM Operations Manager?

RSH.exe was removed as part of the standard install from Windows Vista and wasnt re-introduced in Windows 7 either. if its not installed, you will need to install the Windows7 package from MS for this utility.

http://www.microsoft.com/en-us/download/details.aspx?id=2391

DFM Operation Manager - (DFM - Data Fabric Manager). Its is a Web Based Console for managing NetApp Appliances, which ran from a Windows Server.

http://www.netapp.com/uk/products/management-software/operations-manager.html?euaccept=true.

It required a license, but allowed for multiple appliances to be managed by it, bit like VCenter for ESX.

It als had a ClusterConfig checking feature.

christin

Please send your feedback using the URL below:

http://support.netapp.com/NOW/download/tools/cf_config_check/

Regards,

Christine

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public