VMware Solutions Discussions

Trying to create a LUN and add it as storage in VMware esxi4.1


I am trying to add a storevault S500 as my main storage in VMware Vsphere Client. When i  go into storage, add storage, and choose disk/LUN and hit next, it  doesnt show my LUN. I have created the LUN on the S500 and tried to configure  correctly (mapped it to the iscsi name that is generated in the ISCSI initiator in 'dynamic discovery' in vsphere client) .  I want to be able to see the 'test' LUN  when i go to configuration, storage adapters, and 'add  storage' in vsphere client. Attached are screen shots of my configuration of  iscsi on vmware, and my LUN on the storevault S500. What am i doing wrong to cause the new LUN to not show up? To add the Storevault S500 LUN in vsphere client,  I am doing a 'rescan all' and then storage, add storage, and I choose 'Disk/LUN' and hit next.



From your ESX configuration you should be able to click on storage adapter.  Then rescan from there.  If you don't see the path to the storage it won't work.  iSCSI is tricky..

You MUST have the credential corrects, and you MUST have the exact name for the target in the iSCSI initiator to match the storage controller AND you MUST have the storage controller configured to allow the ESX iSCSI initiator configure for it to connect.

If any or all of these are not done, you will not be able to connect.  Keep it simple (for now) disable chap or authentication, just let it connect with no login (you can always change it later).  Also configure the firewall (for ESX) to allow the NIC you created with vKernel to allow the iSCSI to be able to connect as well.

Also with the new servers SOME NIC controllers need to be bound to the controller via iSCSI, but the ESX host uses a iSCSI iniator software that ALSO must be configured, and the HBA must be bound to that iSCSI initiator as well.  Doesn't this sound like fun?

Serioudly it's not as hard as it sounds.. but it does mean checking a few things.  Screen shots help a lot.. just FYI


were you able to open the attachment in my first post called LUN_vmware.doc? It has screen shots of the whole thing. If so, does it look like everything is correct?  When creating my LUN, what needs to be the same between it and the iscsi initiator?  When going into the properties of the iSCSI software adapter and putting in the IP of my storage controller, it creates a target name in the 'static discovery' tab called iqn.1992-08.com.netapp:storevault.  Does that need to match somewhere in the properties of the LUN? I tried creating an initiator group with that name.


This seems to be a more appropriate place to post. Were you able to resolve this issue? If so, would you please let me know how you managed to do it? I'd appreciate any directions on this. Im having the same problems after I upgraded my esx host to esx4.1 (from 4.0). Thanks!


I'm not very keen on this specific storage array, but I have experienced the issues you are facing.

Verify you have the VLAN configurations set properly. If you are using NIC teaming (LACP) ensure you have configured your NICs appropriately on the ESX host. Sometimes an upgrade can mess with the network settings, reverting your NIC teaming settings to default.

Of all the issues I have had with iSCSI, they have all been related to networking or VLANs on the ESX host.

Also verify iSCSI is enabled on the ESX host. Sometimes an upgrade can mess with that as well.

I only reinstall ESX, upgrading is full of too many what ifs.