VMware Solutions Discussions

Highlighted

VMware SRM - SRA error occurred warning

Posting this in case it assists anyone with a similar issue

 

We encountered an error whilst configuring VMware Site Recovery Manager. Sites fail to pair, SRM shows error "SRA error occurred" appears, without any further information.  After uploading the SRA plugin to the SRM Appliance, the Storage Replication Adapters page in SRM reports the message No storage replication adapters installed.

Found this issue on NetApp  KB:  https://kb.netapp.com/Advice_and_Troubleshooting/Data_Storage_Software/Storage_Replication_Adapter_for_Data_ONTAP/Site_Recovery_Manager_Virtual_Applia... 

 

Issue is caused by VSC Appliance Administrator password consisting special character $. (In our case we struggled to reset the VSC administrator and maint password so we had to redeploy the VSC-SRA appliance as well)

Resolution:  To reset the VSC admin password to one without a '$' sign. (refer to above NetApp KB)

 

Client environment details:

  • FAS2750 running ONTAP 9.7P5
  • Netapp Unified Virtual Appliance for VSC, VASA Provider, SRA 9.7P2
  • NetApp Storage Replication Adapter 9.7P2
  • VMware vSphere 7
  • VMware Site Recovery Manager 8.2.0.2 Virtual Appliance

 

Realised it wasn't a VMware SRM issue as the "SRA error occurred" error was resolved in SRM 8.2.0.2: https://docs.vmware.com/en/Site-Recovery-Manager/8.2/rn/srm-releasenotes-8-2.html 

 

1 REPLY 1
Highlighted

Re: VMware SRM - SRA error occurred warning

Hi,

 

I am sorry that you encountered this problem.  We have addressed it with a fix that is targeted to the next release.  For more information, see: http://support.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=1324536

 

---Karl

Check out the KB!
Knowledge Base
All Community Forums
Public