VMware Solutions Discussions

VSC 4.0 Not Scanning (Optimization and Migration)

DORGILLMSTATES

Installed VSC 4.0 on vCenter 4 and while all other functions work correctly, the Optimization and Migration tab never scans any storage. Also, even after trying a manual scan, the storage says Last Scanned: Never.

Tried to uninstall, reinstall, several times.

10 REPLIES 10

DORGILLMSTATES

Still looking for a solution here. Tried several different servers and methods with the same results. We can see the filers and it is reading fine but will not scan properly for Optimization and Migration.

crocker

is this one that your team handles or should the question get posted in the NetApp Support Community

DORGILLMSTATES

Ok, since I am new to the Netapp community, can you please guide me on which location I should post this in or where to proceed from here?

crocker

Hi,

If Allan's team does not provide help, you can post your question in the NetApp Support Community where we have external and internal subject matter experts answering questions about SnapX products and software.  If you have a NOW login, this link enables you to engage them about this.

Mike

willier

Is mbrtools (mbrscan and mbralign) installed on the ESXi hosts? If not, you can do so using the following step-by-step reference http://www.unitek.com/training/netapp/blog/2011/12/install-mbrtools-esxi-server-2/.

kumaraysun

Hi Dustin

We faced the same issue in our environment, the issue was due to RBAC for the VSC role that we created. We changed the capablity to * (root access) to get this working.

The RBAC given for VSC2.0 is not working for this scan and we raised a case with Netapp and we are stil waiting for an answer

regards

Kumaresan

willier

Take a look at KB 2016839 and see if it helps.

DONALD_R_GRAY

I had several issues with mbrtools.

#1 /opt/ontap disappears on reboot

fixed by placing the archive on one of my datastores and updating rc.local to extract every boot and change ownership of the extracted files so vpxuser owned the files

#2 on the san controller I had to set options httpd.admin.enable on


willier

The KB referenced in my earlier reply covers #2 in detail.

DONALD_R_GRAY

#1 is also referenced by your link on the 5th post, doesn't mean it is correct, well it is correct until you reboot the esxi(5) host.

What happens is that /opt/ontap does not persist reboots, even of you run auto-backup.sh

What needs to be done is add  the following to /etc/rc.local

cd /

tar -xvzpf /vmfs/volumes/path_to_my_datastore/distfiles/mbrtools_esxi.tgz

chown -R vpxuser:root /opt/ontap

find /opt/ontap -type f | xargs chmod 755

Then run auto-backup.sh

#2 is _also_ documented on page 31 of the VSC 4.0 installation and configuration guide, not sure why they wrote a KB.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public