VMware Solutions Discussions

VSC supports vFilers?

fletch2007

Hi, I just upgraded to the latest VSC 2.1.1 and was hoping to see the long awaited multi-store (vFiler) support.

We are 100% Netapp vfiler datastores and with vSphere 5 we're looking forward to the VAAI goodness.

But is VSC 2.1.1 supporting vFilers ? - I'm running NetApp Release 7.3.5.1P2

I don't see them appearing in VSC - its all blank:

vfilers are still not supported? If so - what extra config is needed?

thanks

http://vmadmin.info

9 REPLIES 9

fletch2007

According to

http://communities.netapp.com/docs/DOC-6534

vFilers should be discovered as of VSC 2.0 and Ontap 7.3.1.1 - so I'll need to troubleshoot why they are not in my case

MultiStore vFiler unit support

Does VSC support MultiStore vFiler units?

  • Yes, vFilers are now supported as of VSC 2.0.
  • vFilers are discovered in the same manner as physical controllers.
  • vFilers have the same ONTAP version restrictions as physical controllers.
  • All vFiler hostnames will be pre-pended with "MultiStore:" in the hostname of the Overview panel.
  • VSC only communicates with the vFiler.   VSC cannot determine the physical controller (aka vFiler0).
  • vFiler storage totals will be calculated by adding up all the available storage owned by the vFiler. vFilers don't have a concept of disks like physical controllers do.   The Total Capacity and Total Allocated columns will be the same.

What version of Data ONTAP is required for vFiler support?

  • Data ONTAP 7.3.1.1+ is required for VSC to discover vFilers.  Please see the NetApp Interoperability matrix for specific support configurations.

What VSC features are not available on a MultiStore vFiler unit?

  • vFilers do not support SSL.
  • Supported protocols column – The column displays the license protocols allowed by the controller. As mentioned above, VSC only talks to the actual vFiler. When a controller is a vFiler unit, the "supported protocols" column will be presented as the protocols "in-use". For instance, if an NFS export is found by VSC, NFS will be listed. If an iSCSI LUN is discovered as well, both NFS and iSCSI will be listed.
  • Overall Status column – This column displays the operational state of the controller.   If VSC is communicating with the vFiler, it's in the "running" state. To be consistent with physical controllers, a state of "running" will be presented as "Normal". vFilers in any of the other 4 states (these are non-operational states) will not be discoverable by VSC.
  • Overall Status Reason – This column displays the details status returned by the controller. vFilers do not return a status reason, so the following string will be printed for the status reason: "This controller is a MultiStore vFiler unit."
  • The following columns are not applicable for vFilers. These will be left blank.
  • Controller partner
  • CFmode
  • CFmode status
  • FilerView cannot be launched from VSC on vFilers

fletch2007

So I found some vFilers are being discovered now, but others are showing up as unknown and it seems those don't have SSL enabled.

secureadmin shows the ssh is enabled, but where is ssl configured on the vfiler level?

secureadmin status                       

ssh2    - active

ssh1    - active

thanks

scottgelb

You have to set options httpd.admin.enable on on each vfiler... "vfiler run * options httpd.admin.enable on" should take care of it...vfiler0 too. 

fletch2007

The vFilers are showing up now - but it really SUCKS there is no support for VAAI with vFilers

Anyone know when VAAI + vFilers is coming?

thanks!

ccolht

The vfiler still won't talk HTTPS.

scottgelb

Correct.. But the option is required on to work with vsc.. Odd but how it was implemented.

Typos Sent on Blackberry Wireless

ccolht

Yes, httpd must be enabled. I was just responding to the question about ssl. Some of the limitations make sense since the vfiler can't do things like resize a volume. I run central vfilers dedicated to vmdk exports and separate vfilers for each customer's data access (luns and shares.) The esxi hosts and vcenter can't reach the customer vfilers so they can't and shouldn't manage that storage.

scottgelb

Good point and good to know the use case. You don't have an rcu requirement or do you use other methods to clone?

ccolht

SSL is not currently supported in vfilers. You have to uncheck SSL. For provisioning through VSC, I target the base filer and then set the vfiler 'Context' to the right vfiler.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public