VMware Solutions Discussions

Vibe Error


I am using vibe to schedule backups of NFS volumes for VMWare and have gone thru the VIBE scheduled task and have come to realize the VIBE induced snapshots are failing with an error code of 0xb.

Here is the info from the log.



[10:21:15] VIBE Version: 1.0.3

[10:21:15] Log Filename: C:\Program Files\NetApp\VIBE\Report\VIBE_20080828_102115.log

[10:21:15] Backup Start Time: Thu Aug 28 10:21:15 2008

[10:21:15] Datastore(s) selected: vmtier1

[10:21:15] Datastore snapshot prefix will be used (VIBE_ds_snap).

[10:21:15] Command line arguments successful.

[10:21:15] Initializing connectivity to Virtual Center and storage appliances.

[10:21:15] Converting Virtual Center hostname to IP address ...

[10:21:15] Attempting to ping Virtual Center ...

[10:21:15] Ping of Virtual Center successful.

[10:21:15] Testing login to Virtual Center ...

[10:21:16] Virtual Center login successful.

[10:21:16] Attempting to ping storage appliance ...

[10:21:16] Ping of storage appliance successful.

[10:21:16] Testing shell login to storage appliance ...

[10:21:16] Running remote shell command: version -b ...

[10:21:16] ERROR: Running 'version -b' failed: 512

Do you have any idea why this may be happeing?



This can occur for a couple of reasons. If your 'rsh' access to the NetApp storage controller is failing, you'll get this response. You need to verify that 'rsh -l root version -b' works from the shell prompt as the same user you are running VIBE as. Check the FilerView /etc/messages logs (or login to the console and wait for any authentication errors). Verify that RSH is enabled on the NetApp storage controller and that your hosts.equiv entry has the right fields set.




Thank you for your reponse Matt. I have verified that rsh works from the command line on the machine I am trying to connect from.

I have since run vibe from the command line and am getting a more specific error about NO IP address found for the NFS datastore.

C:\Program Files\netapp\VIBE>vibe --backup --vcip=localhost --vcuser=vm_local --
vcpasswd=Welcome1 --sauser=vm-vibeuser --dsset=vmtier1:storebosp02
WARNING: --sapasswd not defined on command line.
Enter password for storage appliance(s) (username for all: vm-vibeuser):(I entered the password here)
ERROR: No IP address found for NFS datastore vmtier1!

I have attached the log. The datastore is discovered and shown as available, then we get the no IP address found for NFS datastore message.

Any help would be greatly appreciated.

Thank you,



In looking at your log, it is finding the NFS datastore properly, but it can't correlate the datastore to any IP address/path that you have specified in your NFS datastore mount. What this means is, when you connected up your NFS datastore, you did something like When it's looking for that IP address, however, it's not finding for the NetApp controller specified.

I see three IP addresses in your log (,, and but it's not finding that based on the name/IP address you used on the ESX server.

This can happen for a few reasons:

1) You used <hostname>:/vol/<volname> when you connected your NFS datastore, and <hostname> doesn't resolve to any of the IP addresses above;

2) You have multiple datastores named 'vmtier1';

3) Your NetApp controller specified is incorrect (--saip or --vmset IP option) which means it's looking at the wrong controller for that datastore.

Let me know if any of these are the case. Typically it's (1) or (3), and (2) is something we've seen in rare cases where someone uses duplicate datastore names.




Hello Matt,

It was #1. The ESX servers had mounted the volumes as storebosp02_nfs:/vol/vmtier1_data/vmtier1. We put an entry for storebosp02_nfs- into the host file on the vcenter server. The command line approach then started to work. We could still not get the vibe to work as a windows scheduled task using the vibe config files. We have instead placed the entire command directly into the windows scheduler and this is working. Thank you very much for your responses. They were very helpful!