VMware Solutions Discussions

Vmware SRM 5.1 with Netapp SRA issue


I'm trying to setup VMware SRM with netapp simulator 8.1.1,

I created the volume in the PR site and its snapmirred to the DR, .

during the SRM configuration, in the array managers, I added SRA on both sites and it added successfully.

But when I tried to enable the array pair, the PR site get paired with DR site with out any issue, the DR site is showing error as follows.


  SRA command 'discoverDevices' failed. SAN or NAS device not found

Ensure that the SAN device is configured and mapped to an igroup of ostype vmware and the NAS device is configured and exported with rw rules.

I checked the options httpd on the   simulator, it shows as follows.

DR-NODE1> options httpd

httpd.access                 legacy

httpd.admin.access           legacy

httpd.admin.enable           on

httpd.admin.hostsequiv.enable off

httpd.admin.max_connections  512

httpd.admin.ssl.enable       on

httpd.admin.top-page.authentication on

httpd.autoindex.enable       off

httpd.bypass_traverse_checking off

httpd.enable                 off

httpd.ipv6.enable            off

httpd.log.format             common

httpd.method.trace.enable    off

httpd.rootdir                /vol/vol0/home/http

httpd.timeout                300

httpd.timewait.enable        off

Please find the attachment for the SRM error screen.




  I am have the same issue that you are seeing here. Did you manage to fix this and how ?



Hi Paul

When its NFS: Do you have exported the Qtree or the Volume? In the Past it was a Problem, when you export

the Qtree. I dont know, wether its still a Problem.




Are there any VM’s on the volume/”replicated device”?

Have you checked the volume include/exclude lists?

Options httpd.admin.enable ?



Dear All,

please find the following discussion for answer



Hi ,

  Yes there are replciaed machines on the voluome and I have had to enable this that to add the array in to SRM manager to work, but now when scaning after the enabling, this is were I get the same problem.




I'm not sure if you found a permanent response to this, but there are a couple of things I wanted to add in case you're hitting them:

We often see this when snapmirror.conf is setup incorrectly, or DNS between all of the sites and hosts isn't working properly.  If the snapmirror update functions between the simulators (snapmirror update), then make sure that the DNS to the simulators works from the hosts that are running the SRA.

If you are running SRA 2.0.1, which is required for use with SRM 5.1, then you must list all volumes in the "Volume Include List" within the array managers to force the DiscoverArrays to match replicated devices properly.  This is documented in BURT http://support.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=642115

If you have any "mistakes" in the exports file, or are listing the exports with the -actual option, or you've got a volume in the exports list more than once, you will also end up with this error.

To help troubleshoot and narrow down "where" the problem is coming from, you can check the audit logs from the simulator to see if the IP address of the SRA is actually sending ZAPI calls to the simulator, if it's not, then you will know the problem is within the configuration of the SRA; if it is, then you know the problem is with the configuration on the controller itself.


I had a similar issue on a production system, but it was the "options httpd.admin.enable on" that fixed it for me. 

EDIT: I ran into this again on a re-installation and reconfiguration run, and discovered an old export from a previous test run laying around that it was attempting to remount.  Once I cleaned up the /etc/exports and did a "exportfs -a" it went fine.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner