VMware Solutions Discussions

When VAAI NAS Plugin is installed on ESXi 5 no Copy / Sorage vMotion is possible

vMarkus_K

VMware Versions:

/ # esxcli software vib list | grep NetApp

NetAppNasPlugin                1.0-018 

# vmware -vl

VMware ESXi 5.1.0 build-1117900

VMware ESXi 5.1.0 Update 1

NetApp Version:

netapp-07> version

NetApp Release 8.1.2P3 7-Mode: Wed Feb 20 19:56:22 PST 2013

------------

Problem:

 

No Clone or Storage vMotion possible when VAAI NAS Plugin is installed (by vcenter or vmkfstools).

All VMs on both filer nodes are affected.

LOG of vmkfstools clone:

/vmfs/volumes/ec4e3e51-985cfc6d/TPLW2K8R2DCE_MSDN # vmkfstools -v 9 -i /vmfs/volumes/netapp-07_w2k8_000/TPLW2K8R2DCE_MSDN/TPLW2K8R2DCE_MSDN.vmdk /vmfs/volumes/netapp-07_w2k8_000/TPLW2K8R2DCE_MSDN/bck/TPLW2K8R2DCE_MSDN.vmdk_clone

DISKLIB-VMFS  : "/vmfs/volumes/netapp-07_w2k8_000/TPLW2K8R2DCE_MSDN/TPLW2K8R2DCE_MSDN-flat.vmdk" : open successful (285) size = 42949672960, hd = 0. Type 3

DISKLIB-VMFS  : "/vmfs/volumes/netapp-07_w2k8_000/TPLW2K8R2DCE_MSDN/TPLW2K8R2DCE_MSDN-flat.vmdk" : closed.

DISKLIB-VMFS  : "/vmfs/volumes/netapp-07_w2k8_000/TPLW2K8R2DCE_MSDN/TPLW2K8R2DCE_MSDN-flat.vmdk" : open successful (14) size = 42949672960, hd = 282529976. Type 3

DISKLIB-DSCPTR: Opened [0]: "TPLW2K8R2DCE_MSDN-flat.vmdk" (0xe)

DISKLIB-LINK  : Opened '/vmfs/volumes/netapp-07_w2k8_000/TPLW2K8R2DCE_MSDN/TPLW2K8R2DCE_MSDN.vmdk' (0xe): vmfs, 83886080 sectors / 40 GB.

DISKLIB-LIB   : Resuming change tracking.

DISKLIB-LIB   : Opened "/vmfs/volumes/netapp-07_w2k8_000/TPLW2K8R2DCE_MSDN/TPLW2K8R2DCE_MSDN.vmdk" (flags 0xe, type vmfs).

Destination disk format: Thin

Cloning disk '/vmfs/volumes/netapp-07_w2k8_000/TPLW2K8R2DCE_MSDN/TPLW2K8R2DCE_MSDN.vmdk'...

Failed to clone disk: The system cannot find the file specified (25).

/vmfs/volumes/ec4e3e51-985cfc6d/TPLW2K8R2DCE_MSDN # tail /vmfs/volumes/netapp-07_w2k8_000/TPLW2K8R2DCE_MSDN/TPLW2K8R2DCE_MSDN.vmdk

ddb.adapterType = "lsilogic"

ddb.thinProvisioned = "1"

ddb.geometry.sectors = "63"

ddb.geometry.heads = "255"

ddb.geometry.cylinders = "5221"

ddb.uuid = "60 00 C2 90 1b 59 bb 6e-88 36 ed 03 85 54 75 c3"

ddb.longContentID = "6f127b9a168b3d4d0fd3c3c545abcd44"

ddb.toolsVersion = "9221"

ddb.virtualHWVersion = "9"

ddb.deletable = "true"

/vmfs/volumes/ec4e3e51-985cfc6d/TPLW2K8R2DCE_MSDN #

Netapp options and stats:

netapp-07> options nfs.vstorage.enable

nfs.vstorage.enable          on 

Server nfs vStorage copyoffload: (0 calls)

copy_notify    copy_revoke    copy           copy_abort     copy_status

0 0%           0 0%           0 0%           0 0%           0 0%

2 REPLIES 2

robv

Hi,

 

I am also having the same issue. Customer is running 8.2P3

 

Anybody know if this issue is solved in 8.2.1 or 8.2.2 ?

 

Thanks in advance!

 

Rob Verhoeven

alexmattes

Hi Markus,

are you using the -actual Parameter in your /etc/exports. We had exactly the same issue when we we're using the -actual parameter with multiple directories:

Here is an example with -actual which is working:

/esx-datastore-01 -actual=/vol/esx-datastore-01/ESX,root=....

With multiple / in the actual path the plugin is not working. I think this is mentioned in the release notes or the IMT but I could find it right now.

I'm hoping that will help you with your issue.

Cheers Alex

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public