VMware Solutions Discussions

can't configure mpath in ESX host.


I have an esx 4.0 U1 host connected via FCP to a netapp 3070 with DataOntap Version and I can't seem to use the ESX host utilities 5.2.1 to set the prefer path or even to view the configuration. I've tried just about anything i can think of, like adding the host to the hosts.equiv file and set it to use the root account. I ahve removed and re-installed the utilities rebooted the host and I still can't get the config_mpath -q to show anything I get the following error message? I've doubleched check the user password and it checks out, even after I re-installed it I install it ./install --access option and entered the correct credentials. At that point it was able to coonect to the netapp but still I can't use any of the config command to view or do anything in the netapp.

Error: An Authentication failure occurred connecting to pasnasan5

Determining Primary/Proxy paths for LUN=naa.60a98000486e5937504a5a776a315277

Error: An Authentication failure occurred connecting to pasnasan5

   The script was unable to login to all the connected
   NetApp storage system(s) due to improper credentials.
   Please specify the correct credentials for the following controller(s):
   The script was unable to set the correct path settings
   for your configuration.  After the proper credentials have been
   determined, run the following command to ensure the proper paths are being used:
      /opt/netapp/santools/config_mpath --primary --loadbalance --persistent --access <controller>:<login>:<password>

Please let me know what I might be doing wrong.




With these versions of Data ONTAP and ESX it is actually recommended to use ALUA which does not require setting of preferred path anymore.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.