The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

VMware Solutions Discussions

mbralign 5.2 strange issue

languillet

Hi all,

When i use mbralign (release 5.2), it seems that the tool does not find the vmdk.

Release 5.1 of mbralign (and mbrsscan) works fine.

In this example, i use mbrscan 5.1 on a vmdk and try to use mbralign 5.2 on the same vmdk :

[root@esx1 VM_VCENTER]# /opt/netapp/santools/mbrscan VM_VCENTER-flat.vmdk
--------------------
VM_VCENTER-flat.vmdk p1 (NTFS)  lba:63  offset:32256    aligned:No
VM_VCENTER-flat.vmdk p2 (Dell)  lba:70959105    offset:36331061760      aligned:No
--------------------
[root@esx1 VM_VCENTER]# /opt/netapp/santools/mbralign VM_VCENTER-flat.vmdk
grep: /vmfs/volumes/486ea868-33938f98-ea4f-001a64c16e40/VM_SQLSERVER/VM_SQLSERVER.vmx: Device or resource busy

Control-C detected, cleaning up files.....................................DONE
Restore the Virtual Machine using the mbralign-backup file if alignment did not complete.

Does someone know if it is a bug or did i miss something ?

Release of our ESX : 4.0. upd 2

17 REPLIES 17

rodrigon

I had the same issue.

My workaround was mbralign 5.1.

Let me complete this info. I installed an ESX 4.0, put it on my ESX Cluster and aligned my VMs from this host.

See you,


Nasc

NetApp - Enjoy it!

HSAVELKOUL

I read here (http://communities.netapp.com/thread/14540?tstart=0) that there are some corruption issues with running mbralign 5.1 on ESX4.1 so I'd rather not do that

rodrigon

Yes, you are right!

Let me complete my info. I installed an ESX 4.0, put it in my ESX Cluster and aligned my VMs from this host.

See you,

Nasc

NetApp - Enjoy it!

pedro_rocha

Hi,

Just updating you guys about the opened case I have about this issue.

NetApp said this is a BURT and it is documented here: http://web.netapp.com/~burt/views/457/457464.html

mbralign's next version will be addressing this and we should have no problems. They do not know when this release will be coming out though.

Regards,

Pedro Rocha.

droach

That link does not work for me.  web.netapp.com does not exist.  Is the bug ID # 457464?  When I look that ID# up there is no information associated with it.  Could you verify your link?

pedro_rocha

Hi man,

Actually I think that is a NetApp internal webpage. I am trying to get the information on it with the engineer that owns my case. I'll post here when I get that.

Regards,

Pedro

bazmercer

Hi,

Did you get anywhere with this?

Thanks

pedro_rocha

Hello,

Still no. The bug continues opened, and it had an update last friday. No fixed-in version available yet...

Regards,

Pedro.

dgshuenetapp

Oh come on, really?  NetApp, where ya at with this one?  Not going to attempt 5.1 with ESX 4.1 U1... to risky for me.

droach

I am having the same problem.  After the 5.1 version of mbralign corrupted our templates (known issue apparently) I downloaded and extracted mbralign from the Virtual Storage Console v2.1.  I can get it to '--scan' and '--preview' the vmdk file just fine.  But, when I recall the command and remove the '--scan' or '--preview' the tool sits there for about five minutes and then come back with:

grep: /vmfs/volumes/4d822b0b-552c30ef-a3b7-00145e7b71cc/SERVERVM224/SERVERVM224.vmx: Device or resource busy

grep: /vmfs/volumes/4d822b0b-552c30ef-a3b7-00145e7b71cc/SERVERVM195/SERVERVM195.vmx: Device or resource busy

Control-C detected, cleaning up files.....................................DONE
Restore the Virtual Machine using the mbralign-backup file if alignment did not complete.

here is my original command:

./mbralign /vmfs/volumes/4e2dbd54-8426cc99-08bd-e41f131f14ba/SERVERVM232/SERVERVM232.vmdk

The tool looks like it is dancing through some other datastore folder. 

What's up NetApp...I thought mbralign was a supported tool.  How about some answers or at least a reply?  Does this version work for anyone?

pedro_rocha

Hi there,

I have an opened case with NetApp about this. Until now, thery're talking to senior engineers to see why this is happening. On the first contact they did not know what could be causing the issue.

I'll post their answer here when I have it.

Regards,

Pedro Rocha.

droach

Any news yet?

pedro_rocha

Nothing yet... I just checked the case status and for my surprise it was closed without my knowledge. I have reopened it and let's see what happen.

As a workaround, I was able to use the previous version... if you need this for immediate action, I'd recommend this.

I'll post here when I get some answers.

Regards,

Pedro

HSAVELKOUL

Same problem here also. Scan works fine, but when trying to align the machine it seaches every datastore, then comes up with the message:

The same vmdk was found in multiple vmx files.

Please give explicit path to vmdk file location

This is not the case. the vmdk is only used in one VM.

When I try to specify the explicit path to the vmdk file location it comes up with the same error stated above.

pedro_rocha

So, anyone did manage to solve this?

brendan80

I am experiencing the same issue, did we ever get to the bottom of this one?

languillet

No, no solution.

I used the old release and it works fine.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public