Active IQ Unified Manager Discussions

API Services Install Trouble


So when I run the binary to install API 2.0, it installs everything , but gives me an error that it can't start the service. During the installation, I did not get the prompt for the http URL that the documentation mentions, so something is messing up in the install. I've included the output below if anyone wants to help me troubleshoot it:


Installing : ocie-serverbase-7.2.0-2017.06.J62.x86_64 1/6
Installing : netapp-application-server-7.2.0-2017.06.J62.x86_64 2/6
Installing : netapp-platform-base-7.2.0-2017.06.J62.x86_64 3/6
/bin/rm: cannot remove â/var/log/mysqld.logâ: No such file or directory
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.jboss.modules.ClassLoaderLocalLoader$1 (file:/apps/ocapi/essentials/jboss/jboss-modules.jar) to method java.lang.ClassLoader.getPackage(java.lang.String)
WARNING: Please consider reporting this to the maintainers of org.jboss.modules.ClassLoaderLocalLoader$1
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
Installing : ocie-server-7.2.0-2017.07.J97.x86_64 4/6
Installing : ocie-au-7.2.0-2017.07.J97.x86_64 5/6
keystore : [/opt/netapp/data/ocie/server.keystore] is up to date
Installing OnCommand API Services
Installing : api-server-2.0.0-1708220330.x86_64 6/6
Succcessfully created Keystore file.
Post Install config of OnCommand API Services.
Nov 27, 2017 10:38:47 AM java.util.prefs.FileSystemPreferences$1 run
INFO: Created user preferences directory.
Redirecting to /bin/systemctl start mysqld.service
Starting OnCommand API Services...
ERROR 1146 (42S02) at line 1 in file: '/opt/netapp/api-server/api-tools/config-performance-metrics-history.sql': Table 'netapp_model.param' doesn't exist
Failed to execute config-performance-metrics-history.sql file
warning: %post(api-server-2.0.0-1708220330.x86_64) scriptlet failed, exit status 1
Non-fatal POSTIN scriptlet failure in rpm package api-server-2.0.0-1708220330.x86_64
Verifying : ocie-serverbase-7.2.0-2017.06.J62.x86_64 1/6
Verifying : api-server-2.0.0-1708220330.x86_64 2/6
Verifying : netapp-platform-base-7.2.0-2017.06.J62.x86_64 3/6
Verifying : netapp-application-server-7.2.0-2017.06.J62.x86_64 4/6
Verifying : ocie-server-7.2.0-2017.07.J97.x86_64 5/6
Verifying : ocie-au-7.2.0-2017.07.J97.x86_64 6/6

api-server.x86_64 0:2.0.0-1708220330 netapp-application-server.x86_64 0:7.2.0-2017.06.J62 netapp-platform-base.x86_64 0:7.2.0-2017.06.J62
ocie-au.x86_64 0:7.2.0-2017.07.J97 ocie-server.x86_64 0:7.2.0-2017.07.J97 ocie-serverbase.x86_64 0:7.2.0-2017.06.J62

Error OnCommand API Services is not yet started
Exiting installation



Thanks for the help.



Looks like there is an unsupported java version is installed . 

Can you please check 


$java -version 


$rpm -qa | grep -i java


If there is unussported java version installed then  please point to appropriate one . cleanup the stale entries and  start the installation  . 


Please let us know if you come across problem in installation


I have the same issue, with same error. API 2.2


rpm -qa | grep -i java