Active IQ Unified Manager Discussions

DFM Provisioning Manager Problems


I was wondering if anyone has some tips on how to use the Provisioning and Protection manager.  I've been messing around with this thing for a couple of days now and as soon as I think I've isolated my problem anohter pops up.    Here's what I'm tryint to do:  Create a Dataset with the Mirroring protection policy and provision storage for VMWare hosts

Here's my setup:

netapp1 - Simulator Filer ONTAP 8.1 7-mode

  snapmirror licensed and configured (I can manually create snapmirror realtionships successfully)

  iscsi licensed and configured

  aggr0 - root

  aggr1 - source

netapp2 - Simulator Filer ONTAP 8.1 7-mode

  snapmirror licensed and configured

  iscsi licensed and configured

  aggr0 - root

  aggr1 - destination

opsmgr - DFM 5.1, Protection/Provision MGR 3.2

Here's what I've done so far that I believe gets me closest to my goal:

1. create resource pool 'source' with netapp1:aggr1

2. create resource pool 'destination' with netapp2:aggr1

3. create new dataset 'test'

3a. accept default 'Naming Properties'

3b. accept Global for 'Group'

3c. assign resources manually

3d. skip assigning physical resources and finish the wizard

4. assign a protection policy of 'Mirror' to the test dataset

4a. assign resources manually during 'modify New Node Resources'

4b. skip assigning physical resources and finish the wizard

5. edit the dataset 'Primary data'

5a. select 'Provisioning/Resource Pools'

5b. add 'source' resource pool to 'resource pools in this node'

5c. select 'Thin Provisioned Space for VMFS Datastores' for the provisioning policy

5d. under iSCSI Export Settings: turn on iSCSI, provide initiator ID, select VMWare for host operating systerm

5e. skip 'enable automated migration'

5f. skip 'Select a vFiler unit' and complete wizard

6. edit the dataset 'Mirror'

6a. select 'Provisioning/Resource Pools'

6b. add 'destination' resource pool to 'resource pools in this node'

6c. For 'IP address for data access' entered the IP for the destination filer and finished the wizard

7. select the provisioning tab and select my test dataset

8. press the provision button

9. use the lun name 'test' and leave default lun space and maximum space of snapshot copies

10. allow the system to automatically select a resource from the attached resource pools

11. **PROBLEM** the Conformance Results show that the vol/qtree/lun was successfully created on the source filer, but give me the following error for the destination:

Error: Provisioning a new flexible volume (mirror destination) failed.

Action: No physical resources exist, so Provision a new flexible volume (mirror destination) of size 3161088kb VoIToBeProvision:test into node 'test:Mirror' and then attemp to creat a mirror relationship.

Reason: Storage system: '

  -Storage system ''(179):

defaultvFilerInterface needs to be configured in order to create a vFiler unit by provisioning capability of OnCommand

Suggestion: Suggestions related to storage system ''(179):

  -Storage system ''(179): Configure defaultvFilerInterface for the storage system using CLI 'dfm host set".

When I follow that suggestion and try the process again I get a set of errors that say that 'The storage system has exhausted the limit of creating vFilers.  There are 1 vFiler units on the storage system and the current limit of maximum number of allowed vFiler units is 0'.  Presumabliy this is because I'm running 7-mode ... I knew this before I tried the DFM "suggestion" but it's all I had to run with.

If anyone can offer any suggestions I would be greatly appreciative.



UPDATE:  noticed that 6c. is for vFilers so I left it blank on one of my other attempts .... still get an error "netapp2 cannot connect to source filer". 

I'm able to ping from one filer to another.  I'm also able to manually establish a snapmirror relationship so I don't get why the protection/provisioning manager cant do it as well ...


You can use the below mentioned commands to set vfiler interface and vfiler limits

Over DFM use the command

dfm host set “storage BOX IP” defaultvFilerInterface="e0a" for example

At Storage BOx


vfiler limit "some number"

reboot the system and u would be able to create the vfiler