If you missed the pre-registration for NetApp MS Azure AD B2C, the new login prompt will offer the option to register. Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

OCI 7.1 DWH DB restore failed

sstrznwra

Hello

 

When upgrade from OCI DWH 7.0.2 to OCI DWH 7.1 the DB restore goes failed.

 

Upgrade Log:

 Caused by: java.lang.StringIndexOutOfBoundsException: String index out of range: -47 

at java.lang.String.substring(Unknown Source)
at com.netapp.sanscreen.dwh.cognos.upgrade.v_7_1.Upgrader_7_1.run(Upgrader_7_1.java:81) 

 

The error only occurs when I restore the DB with "Restore Reports"

 

Does anyone have any idea about it ? Smiley Happy
 
Thanks
Michael
7 REPLIES 7

JBARBALACE

Just thought I'd add a quick note, that I had the same issue today.  The reason provided was: "Failed upgrading cognos data store".  I, too, upgraded from 7.0.2 to 7.1.0.  A little frustrating after waiting 2 hours for it to restore...

 

I'll be opening a case shortly.

 

Good luck!

Julia

slava

Hello guys,

I just hit the same issue after OCIDWH upgrade to 7.1.

Have you been able to figure out what is the solution there?

Regards,

Slava

JBARBALACE

I have a case open with NetApp at the  moment.  The issue for us is that when I try to restore the database and reports together, it fails.  When I restore the database only, it is consistently successful.  When I then try to restore the reports only, failure each time.  I've tried with a restore from 6.4.3 reports and 7.0.2 report backups, but to no avail.  I get the exact same error message you show in your attachment.

 

 

slava

Thanks for response.
I am also in process of restoring database only.
Then will try to restore from 7.0.1.
Regards,
Slava

sstrznwra

Hi,

 

You must remove all Slashes from the Report Name.

 

/content/folder[@name='Capacity']/package[@name='Storage and Storage Pool Capacity']/folder[@name='CustomerDashboards']/report[@name='NASFILER01/02 POOLS']

 

Check the dwh_upgrade.log to find Reportnames with Slash

 

Regards

Michael

hotz

Hi Michael,

 

I'm not entirely certain, but do you have custom reports? Especially ones that use the Storage Capacity data mart?

 

Note that the Storage Capacity data mart and Storage Capacity fact table (dwh_capacity.capacity_fact) are removed.

 

But regardless of whether the Storage Capacity data mart is causing the issue or something else, you might want to open a case with NetApp support. This looks like a bug to me.

 

Kind regards,

Gerhard

sstrznwra

Hi Gerhard

 

Thanks for the quick response, I know the Storage Capacity Datamart is removed in 7.1, I have 2 reports that used this datamart.

I delete this reports  on 7.0.2 DB , but the same error on restore to 7.1 dwh.

 

at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.StringIndexOutOfBoundsException: String index out of range: -47
at java.lang.String.substring(Unknown Source)
at com.netapp.sanscreen.dwh.cognos.upgrade.v_7_1.Upgrader_7_1.run(Upgrader_7_1.java:81)
at com.netapp.sanscreen.dwh.upgrade.cognos.CognosContentStoreUpgradeManager.upgrade(CognosContentStoreUpgradeManager.java:46)
... 109 more

 

Is it possible that I have a problem with the language here ?
Windows Server 2008 R2 English

 

I have opend a Case on Monday last Week , the support says the case is passed on engineering.

 

Kind regards

Michael

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

Public