Active IQ Unified Manager Discussions

OCI Data source failing error

Aravind
6,365 Views

Some of the data sources are failing with the error:

 

"Inventory Package has reported conflicting device(s)" .I found some solutions stating that the device is being reported by multiple data sources.

Is there any other reason for such kind of errors. What is the solution to fix this error.

1 ACCEPTED SOLUTION

Anoop
6,289 Views

Hi Aravind,
 
It looks like the same device is being discovered more than once by multiple datasources, hence leading to the error messages. 
 
This is most likely due to the configuration setting “Discover all Fabric switches”. You can either create one datasource for each FC switch or you can configure one datasource per Fabric (and then turn on the Discover all Fabric switches feature). If you have done the former and have this setting enabled, you may run into this issue.
 
If this is the case, you may want to “Edit” the corresponding datasource and uncheck the “Discover all Fabric switches” checkbox and see the issue status. Once the datasource is automatically reconfigured after the change, the message should ideally disappear.

 

Regards,
Anoop

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4 REPLIES 4

Anoop
6,290 Views

Hi Aravind,
 
It looks like the same device is being discovered more than once by multiple datasources, hence leading to the error messages. 
 
This is most likely due to the configuration setting “Discover all Fabric switches”. You can either create one datasource for each FC switch or you can configure one datasource per Fabric (and then turn on the Discover all Fabric switches feature). If you have done the former and have this setting enabled, you may run into this issue.
 
If this is the case, you may want to “Edit” the corresponding datasource and uncheck the “Discover all Fabric switches” checkbox and see the issue status. Once the datasource is automatically reconfigured after the change, the message should ideally disappear.

 

Regards,
Anoop

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

dbourque
6,171 Views

Update: In the upcoming OnCommand Insight 7.2 release, A new widget is available that will detect and report that the same datasource is monitored twice. 

Aravind
6,098 Views

hi,

do you mean that if a device is monitored by two different data sources,then it will be reported.

smcgowan
6,079 Views

That is correct the device is being monitored by more than one datasource.

 

 

https://kb.netapp.com/support/index?page=content&id=S:2026254

 

Inventory Package has reported conflicting device message within OCI Data Source Report

 

KB ID: 2026254 Version: 0.4 Views: 0
Categories: SSCR, Non-KCS, OnCommand Insight Available To:  Public , External , Services Partners (OEM, SSC, PSC) , InternalOwner:  Scott McGowan
 
 
Environment

OnCommand Insight (OCI)

Symptoms

The following error message in Red on your data source report is displayed:

London_S219596SSAU0001okTRUELondon_s219596c9124f9002InventoryTue 01/05/16 03:48 AMCiscoAll models using SNMPInventory Package has reported conflicting device(s)

Multiple collections cause undue CPU and memory cycles on both the OCI server and the device itself.

Cause

We have one or more Data sources collecting on the same device or devices.

The latency and slow device is caused by response by these unnecessary duplication of effort.

Duplicates have also been known to cause DWH ETL failure as well and in older version's of OCI DB corruption.

Solution

Determine which other Data Sources are collecting on the same device and use the exclusion feature within the Data Source configuration to correct the multiple collections.

 

 

Disclaimer

NetApp provides no representations or warranties regarding the accuracy, reliability, or serviceability of any information or recommendations provided in this publication, or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS, and the use of this information or the implementation of any recommendations or techniques herein is a customer’s responsibility and depends on the customer’s ability to evaluate and integrate them into the customer’s operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.

 

 

 

When 7. 2 releases you will need to add the widget below 

Widget.png

Public