Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

OnCommand API Services 1.2 no content

Vijf

Hi All,

 

So i've installed the OC Api Services 1.2 on a RHEL 7.2 system. All is looking good and the interface is availible. 
I can see in the logfiles that it's also pulling information from the clusters. 

Unfortunaly when i do a test GET in the interface no content is shown. 

 

I'm getting the feeling that the data is not being saved in the database. 

Clusters are running:

NetApp Release 9.0P1 

 

Can someone advice what to check?

Thanks! 

 

3 REPLIES 3

Vijf

So this morning i continued with my investigation. 
Turns out that browing directly to the url https://**.**.**.**:8443/api/1.0/ontap/aggregates returns the xml output i that suspected. 
But when i run the "Try it Out" command underneath GET /ontap/aggregates the response body is "no content"

Vijf

So..found the issue.
Appertently browsing with the host name in the url gives me the 'No Content'. When i do the same with ip instead of the hostname i get the results. 

dkorns

Same here. Thanks for the workaround.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public