Active IQ Unified Manager Discussions

OnCommandHSVMware Error 4096


I have had the command operations manager server up and running for several months and i just noticed my event log is full of authentication errors for vmware.  I have one connection setup for vmware and it appears to be reporting the storage correctly but I have errors on the filers syslog and the oncommand servers event logs.

Oncommand Event message:

1011876584 [Storage Refresh] ERROR com.netapp.smvi.zapi.ZAPIExecutorFactory - Unexpected error during refresh of storage system "XXX.XXX.XXX.XXX": ZEPHYR-10004: ZAPI call "system-get-version" to "XXX.XXX.XXX.XXX" threw exception: Authorization failed

com.netapp.common.zapi.ZAPIRunnerException: ZEPHYR-10004: ZAPI call "system-get-version" to "XXX.XXX.XXX.XXX" threw exception: Authorization failed     at com.netapp.common.zapi.AbstractZAPIExecutor.execute(     at     at     at com.netapp.smvi.zapi.StorageTarget.validate(     at com.netapp.smvi.zapi.StorageTarget.refresh(     at com.netapp.smvi.zapi.ZAPIExecutorFactory$RefreshThread.doRefresh(     at com.netapp.smvi.zapi.ZAPIExecutorFactory$ by: netapp.manage.NaAuthenticationException: Authorization failed     at netapp.manage.NaServer.invokeHTTP(     at netapp.manage.NaServer.invokeElem(     at com.netapp.common.zapi.AbstractZAPIExecutor.execute(     ...

On the Filer:

HTTP XML Authentication failed from

I have looked all thru the operations manager and i cant seem to figure out where to put the crentials.  I honestly would like to drop the connection all together to vmware but cant seem to figure that out either.




Found the setting under Host services.   i had a connection setup and within this connection was the vcenter server which had the wrong username and password.


Unfortunately I have a same problem. Could you please share, where or how did you find the connection setup? Thank you.


I'm having the same issue too. Could you please let us know how you fixed it? Thanks.


Check to be performed on OCHP configuration:

  • If we need to confirm the login credentials for vcenter, try "https://vcenterIP/mob" and use the same username and password that is configured or we are trying to use from DFM server if possible.
  • Once the vcenter credentials are confirmed, then go to "Add/Remove" on the OCHP server and "repair" the ochp installer and put the right credentials for vcenter as well as DFM, please see the screenshot, also make sure to check the box for install logs at the end of the wizard and check for any errors.

  • While we are at it, please also look at the Microsoft KB "", as a best practice we need to make sure we deploy this patch on windows 2008 server if that is what we are using for OCHP/DFM.
  • On DFM server we will check few things after we re-run the "repair" setup.

          1) Open command prompt window and type "dfm hs list"

           2) command --> dfm hs diag <HS ID>  "We get the HS ID from the list command"

          3) We can also change the vcenter "username and password" under "edit host services" window, but i rather correct this setting using the Add/Remove program mention above.

          4) To open "edit host service" window, Open up NetApp Oncommand Console --> Administration --> Host services --> Edit host services, Screenshot is given below

Hope this will help correct the credentials or get an idea out of it?


Thanks for the help but I'm sorry to say I am still getting the same error.

In my case it keeps trying to do a "system-get-version" to an ip address that we no longer use. Not sure why its doing it.


Sorry to hear that Paul.

You mention that you have operation manager running for several months and you notice about this errors in the windows events logs, I need some information from your DFM server, can you please provide that information?

  1. What version of operation manager you are using? (command--> dfm version)
  2. Do you use OCHP? (Oncommand Host Package), If Yes, what version of OCHP installed on your server? (command --> dfm hs list <-- Id come from this command is used in the next step)
  3. Do you have NetApp Controller attached to OCHP, If Yes, please send me the output of the following command. (command --> dfm hs controller list <hs Id>)

I will wait to hear back from you. Thanks.


dfm version
dfbm.exe (5.2)
dfdrm.exe (5.2)
dfpm.exe (5.2)
dfm.exe (5.2)
dfmcheck.exe (5.2)
dfmconfig.exe (5.2)
dfmconsole.exe (5.2)
dfmmonitor.exe (5.2)
dfmperf.exe (5.2)
dfmscheduler.exe (5.2)
dfmserver.exe (5.2)
dfmwatchdog.exe (5.2)

eventd.exe (5.2)
grapher.exe (5.2)

dfm hs list

Id                         31978

Host Name          DFMSERVERNAME
Host Address     10.x.x.x
Status               up
Timezone     1:00(1hour East of UTC)

  dfm hs controller list 31978

Id          Controller Name     Access Protocol     Login Status (Host Service)     Login Status (Server)

74         filer1                       https                          good                                       good
75         filer2                       https                          good                                       good
76         filer3                       https                          good                                       good
77         filer4                       https                          good                                       good
1107       filer5                       https                          good                                  good
42321      filerA                                 https                          good                                       good
43752      filerB                                 https                          good                                       good
55726      filer6                    https                          good                                       good

[Storage Refresh] ERROR com.netapp.smvi.zapi.ZAPIExecutorFactory - Unexpected error during refresh of storage system "192.168.x.x": ZEPHYR-10004: ZAPI call "system-get-version" to "192.168.x.x" threw exception: Connection timed out: connect

The error I'm getting is looking for an old IP address as you can see above.

Thanks for the help.

Message was edited by: Paul Coyne Made it readable.


Thanks Paul

This will require further investigation, i will request you to please create a case and one of us will help you out.


Was anything ever found out on how to remove the stale host?  I just realized I have this same problem when my certs failed on the HS hosts.  I am getting the following:


10316876 [Storage Refresh] ERROR com.netapp.common.zapi.ZAPIExecutor - ZEPHYR-10004: ZAPI call "system-get-version" to "192.168.X.X" threw exception: Connection timed out: connect


All of the HS hosts are reporting correctly to DFM/oncommand and see no signs of this stale host anywhere.





I have the same issue... did you get any solution ?