The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

System Manager 2.0R1 for OSX

jthaloor

I am pleased to announce the unofficial release of SystemManager 2.0R1 for OSX. As with the Beta release, please be warned that YOU CANNOT CALL NETAPP SUPPORT for any problems with the build. You can use this communities site for support but I should set the expectation that not I cannot jump on issues if it is outside of OSX.

25 REPLIES 25

p_w

Hi,

Would please tell me where I can download it?

Kind regards

peter

amritad

Hi,

It's available here:

https://communities.netapp.com/message/98622#98622

Regards

Amrita

wolfgang_riedel

Hi Folks,

if you're getting just a bouncing dock icon, here how to solve it.

Took me hours to find out 😉

Hmm. I may have found a solution to this. It seems to be caused by a bug with Lion's quarantine system. To solve it, I followed the following steps. (Less.app is my example)

In Terminal, I moved to the following:

Replace everything except for Contents/MacOS with the location of your application.


$:  cd /Users/ericskram/Desktop/Less.app/Contents/MacOS

List the files in the directory using ls. There should just be one. In my case, it was named less.

$: xattr less

There should be an entry labeled com.apple.quarantine. If there is, use the following command to remove it.

$: xattr -d com.apple.quarantine less

 

Source: http://reviews.cnet.com/8301-13727_7-57374676-263/workarounds-for-quarantine-bug -in-os-x-lion/

spencert

Outstanding! Works well with my mac book pro 10.7.3 too. Using RDP or a windows VM just to manage the filer was really annoying.... THANK YOU!

jeras

Is there a newer build for the Mac version?  I'm running build eapN_110505_0850 which I believe may be the only build at this point. 

I'm having an issue with the save system credentials feature.  I'll enter the controller log in credentials, check the box to save the credentials and log in successfully.  The next time I attempt to log in, the credentials come back with a user name of "null" and I get an incorrect log in error message based on the "saved" credentials that System Manager is putting into the dialog box.

Thanks!

Ken

amritad

Hi,

The communities supported 2.0.1 MAC build is available here:

https://communities.netapp.com/message/78489#78489

We currently do not officially support Systems Manager on the Mac OSX Platform.

However, we do have a build (based on the current Systems Manager build) that will run natively on a Mac OSX platform.

This will be supported on a best-effort volunteer basis via the communties.

There will be no guarantee for support nor commitment to providing an OSX based client in future releases.

Regards

Amrita

Andre_Clark

Amrita,

Will there be a 2.0.2 version released on OS X since it was just released for Windows and Linux?

amritad

We will be posting a communities supported on;y MAC build soon.

REgards

Amrita

amritad

noc

Working fine on my MacBook Pro under 10.7.3.

I would like to give my opinion that NetApp should GA and support this on Mac OS X.  I find it rather amusing that Apple is the largest technology company in the world, yet so many companies don't take supporting OS X very seriously.  Given the fact that SystemManager is written in Java, multi-platform support should be almost trivial.

mvintinner

On my Mac, the System Manager always loads with a window size of 700x625, which is funny because it doesn't even fit the contents of the login screen.  Every time I run the program I need to resize the window.  Is this just me, or is everyone having this problem?

This has been consistent since running the first beta version (I'm currently running 2.0R1).  I've looked through the config XML files, but didn't see anywhere to change this.  If this is the way it is designed, I'd love to see a more appropriate default window size (maybe 1024x768).

jthaloor

This is the first time I heard about this issue. AFAIK there are no window size settings with in the OSX wrapper. The only thing I can think that can doing this is your default Safari settings. The Webkit UI used for the wrapper uses your default Safari settings as would any webkit App on OSX.

mvintinner

Thanks for the reply.  I'm using an Apple Cinema 27" display running at 2560x1440.  When I load my Safari web browser, it opens up at ~1600x1200.  I've tried running the "Reset Safari" option to reset the browser to the defaults (I never use Safari anyway).  There's also nothing unusual in the Console (no error messages).

If you can think of anything else I can look at, please let me know.

ddknightdd

Hopefully it will be officially supported one day. So far it seems to be a nice product. Thanks.

ajkremer

Just found this, works great on Snow Leopard as well.

Thanks very much for creating this build, really helps operation efficiency.

Thanks again!

murthy_nsm

thanks to everyone for posting the download but  i have a blue Netapp system manager screen when i just install the DMg file after zipping and placed the file inside /library/application/system manager also found this inside /Users/Administrator/Netapp/System Manager but no luck. i have following version of MAC server.

MAC version

Darwin max1 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun  7 16:32:41 PDT 2011; root:xnu-1504.15.3~1/RELEASE_X86_64 x86_64

Java version

--------------------

java version "1.6.0_26"

Java(TM) SE Runtime Environment (build 1.6.0_26-b03-384-10M3425)

Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02-384, mixed mode)

i have also removed systemmanager.config and relaunched System manager but even after that its still blue screen.

Can someone help me how to run and overcome this bluescreen (netapp system manager blue screen) .

BR,

Rushi

luker

Hi,

If it's any help, I had the same behaviour the first 2 times I started the application.

For some reason (luck, I suppose), it worked the 3rd time, and so far has worked every time since.

I'm running Snow Leopard (10.6.8).

You might want to open the console (applications - utilities - console) and see if any errors are being logged when System Manager starts up.

Thanks,

Luke.

illumitltd

Fantastic option; thank you very much - native tools for OS X are a massive benefit for many sysadmins and a credit to NetApp.

Official support would be valuable; please take this as feedback that we definitely do want to be able to run NetApp management tools on OS X.

Thanks again for your efforts.

sraudonis

When i want to login to a System i can't authenticate. I got the following message:

Internal Server Error

==ERROR== com.netapp.nwf.client.communication.ResponseException  ==TIME== 2011-10-07 15:55:41,514  ==MESSAGE== Internal Server Error  ==DETAILS== No details are available.  ==CORRECTIVE ACTION== No suggested corrective action is available.  ==LOCATION== Location is not specified.  ==BROWSER INFO== App Name: Netscape App Version: 5.0 (Macintosh; Intel Mac OS X 10_7_1) AppleWebKit/534.48.3 (KHTML, like Gecko) App Codename: Mozilla User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_1) AppleWebKit/534.48.3 (KHTML, like Gecko) Platform: MacIntel Cookie Enabled: true

What can i do?

sraudonis

O.k. i activated ssl on my simulator and i was able to login successfully. But the second system i tryed was a Ontap 8.1RC, here is ssl already active and i got the same error. And this was in a workshop, so i'm not able to test it again with different settings...

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public