Active IQ Unified Manager Discussions

WFA 4.1rc1 against ONTAP 9.0 and 'Create and configure SVM' command


I believe I've found a bug in WFA 4.1rc1 attempting to use the certified command: 'Create and configure Storage Virtual Machine' (the PowerShell flavor). I've attached a screenshot of Commend TEST button re-creating the error. It could be in WFA 4.0 also but I can't check that. 


I believe the issue has to do with Network Routing-Groups. Routing-Groups were depricated in 8.3 but even more so in ONTAP 9.0. In 8.3 if you would still see routing-groups if you did a network routing-groups show. In ONTAP 9.0 if you do a network routing-groups show you never get anything returned.  


I suspect this is why this WFA command PoSH code is failing with the error: Failed to create the route : Cannot bind argument to parameter 'RoutingGroup' because it is null. 


Same WFA command works fine against an 8.3.2 cluster.


I'm going to have to solve this so if I come up with a fix I'll share.


PS: I believe this is easily re-creatable but if not, let me know. It's possible I'm doing someting wrong that 8.3.2 lets me get away with but 9.0 doesn't. 



FWIW, I get very similar error with the Perl flavor of command ... attached


If I boil this down to the PoSH command that is generating the error and perform it against a 9.0 (sim) and then an 8.3.2 (sim) cluster, it shows it failing on 9.0 but working on 8.3.2 (only different vserver, lif names and ip-address. To me it appears the New-NcNetInterface cmdlet wants or needs a -RoutingGroup paramter but I have no idea what to give it, since Routing-Groups don't exist in ONTAP 9.0 as far as I can tell. I'm going to copy this post over to the PowerShell Toolkit community site and see what feedback I get. 


PS C:\Users\davekorns>
PS C:\Users\davekorns> # First Against a 9.0 cluster
PS C:\Users\davekorns>
PS C:\Users\davekorns> Connect-NcController -cred $cred

Name Address Vserver Version
---- ------- ------- ------- NetApp Release 9.0: Fri Aug 19 06:39:33 UTC 2016

PS C:\Users\davekorns> New-NcNetInterface -Name lt-dscdrtest004 -Vserver lt-dscdrtest004 -role data -node lt-stor-01 -Port e0d -Address -Netmask -DataProtocols @('cifs','nfs')
New-NcNetInterface : Internal error. Routing group not found. Contact technical support for assistance.
At line:1 char:1
+ New-NcNetInterface -Name lt-dscdrtest004 -Vserver lt-dscdrtest004 -ro ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: ( [New-NcNetInterface], EAPIERROR
+ FullyQualifiedErrorId : ApiException,DataONTAP.C.PowerShell.SDK.Cmdlets.Net.NewNcNetInterface

PS C:\Users\davekorns>
PS C:\Users\davekorns>
PS C:\Users\davekorns> # Now Against an 8.3.2 cluster
PS C:\Users\davekorns>
PS C:\Users\davekorns> Connect-NcController -cred $cred

Name Address Vserver Version
---- ------- ------- ------- NetApp Release 8.3.2: Tue Feb 23 23:35:06 UTC 2016

PS C:\Users\davekorns> New-NcNetInterface -Name hq-dscdrtest001-02 -Vserver hq-dscdrtest001 -role data -node hq-stor-01 -Port e0d -Address -Netmask -DataProtocols @('cifs','nfs')

InterfaceName OpStatus DataProtocols FirewallPolicy Vserver Address
------------- -------- ------------- -------------- ------- -------
hq-dscdrtest001-02 up {nfs, cifs} data hq-dscdrtest001

PS C:\Users\davekorns>





We are looking in to the issue, will update you soon.










Your inconvenience is regretted.



I had seen this behavior when making a command for adding Network Routes on ONTAP 9.0


There is also another problem with WFA cmdlet Get-OntapVersionFromString and ONTAP9


I'll give you the the command code with the fix  which I had done for my command Adding network route command.


I'll also give the other fix.


You can use them temporarily till the updated version of the CDOT pack is not available on WFA4.1 and WFA Automation store.








If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


Thanks Sinhaa, I'll look for that (


ALSO, IMPORTANT UPDATE TODAY ... I have 3 ONTAP 9.0 sims to test against. Yesterday all my testing was agaisnt one of them.


This morning after some more testing I've noticed:


    1) I can reproduce this issue with just a simple CLI vserer create followed by a network interface create which also fails with a similar CLI 'routing group not found' error 


    2) HOWEVER, the 2 other ONTAP 9.0 systems I have work fine with the same CLI vserver create, net int create sequence 


So I have some kind of config issue with the 3rd ONTAP 9.0 system I was testing against yesterday. I'm just starting to look into that right now.


But I do need to polish my 'already' custom 'create SVM' WFA command to account for any 8.3 / 9.0 differences. 


While in the above reply I say that I found it was only failing on one of my ONTAP 9 systems  ... an hour later they were all failing again. I even tried a ontap 9.1 vsim. It turns out the routingGroup error was very intermintent ... sometimes I'd get it, sometimes not. Everytime I thought I knew why, it would escape me.


The original problem I was reporting was with the 'Create and configure Storage Virtual Machine' certifed command. That command can be used to BOTH create the SVM and an initial LIF, all in one command. If you leave off the LIF parameters, no LIF is created. So I re-coded my workflow to NOT create a LIF as part of 'Create and config SVM' but instead in a subsequent command-step using certified 'Create logical interface'. Suddenly evening started working as expected, on 8.3.2, 9.0 and even 9.1. 


I was never able to fully understand or resolve the issue but have a reasonable work around.


We hit the same with WFA 4.0 against ontap 9 at a customer site! Any update on this?


For my situation, the problem was when using that command and attempting to fill-out the LIF parameters (ip-addr, etc) to cause it to also create a LIF with the SVM. When I left the LIF related parameters blank, the command worked fine. Then I followed it up with the 'Create LIF' command instead. Two steps, that that methods seems to work for 8.3 and 9.x (I honestly don't remember if it was really an ONTAP-version specific error). That is how we worked around the issue.