Active IQ Unified Manager Discussions

execution URI input line was not set when trying to run wfa commands via powershell


I am trying to run WFA commands via powershell and keep getting above error
tried couple of things
Import-Module 'D:\Program Files\NetApp\WFA\PoSH\profile.ps1'
and also tried below
cd 'C:\Program Files\NetApp\WFA\PoSH\'
. '.\profile.ps1'
any ideas?






I assume you are trying to execute WFA powershell cmdlets like Get-WfaLoger, Get-WfaCredentials etc. from module WFA from a Powershell console. Correct?  This is when you get this exception thrown.



This is expected behaviour. The WFA cmdlets from module WFA can't be called outside of the WFA except for reading the get-help documentation.  See my response on this thread


What is it that you are trying to do with using these cmdlets outside in a Posh console? If you can provide more details, I can try to help.






If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


yes, thats what I am trying to do.

I am trying to run a workflow someone on this forum developed to set annotation in OCI using OCI API,

running into errors and trying to resolve them one by one testing it.

getting below


Could not create SSL/TLS secure channel.


WFA is on 1indows 2012 and SANSCREEN is 2008 servers






This usually means the REST API call was incomplete, URI is the full path for the REST call to issue the command. It would help if you could show what it is you are trying to run. I'm assuming you are trying to execute a WFA Worflow via powershell. 



NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner