Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

no user_quota Data available in WFA Database

NetappA051713

anyone know that kind of issue / problem, futhermore the corrosponding solution?

Thanks a lot for your replies!

Regards Jens

5 REPLIES 5

shailaja

Hi,

Due to the potential volume of data for user quotas, the acquisition of this data from OnCommand/DFM server is disabled by default.

If you have workflows or you are developing workflows that depend on this data, then you can turn it on by:

1. Go to Tools Menu -> WFA Configuration Menu

2. Go to Other tab

3. In the entry for "Disable acquisition for Dictionary Entries", remove the entry "storage.user_quota"

4. The next periodic acquisition (if configured) for your DFM server should acquire the data

5. Or, you can trigger an on-demand acquisition by right click the data source and selecting "Acquire Now"

 

Thanks,

Shailaja

Adai

Hi Shailaja,

                    This is for 7Mode. What about cm_storage Schema ? Do we have anything for that ?

 

Regards

adai

korns

I have run ino the same problem today (~ two years later) but my version of WFA (v2.2) doesn't have the 'Disable acqistion for Dictionary Entries' option that I see. Here is my test-case:

 

=====

I've created two user quotas (smith, jones) on a volume called 'users' as seen here at the end of my /etc/quota file

filer> rdfile /etc/quota

  .

  .

smith user@/vol/users 3145728K - - - -

jones user@/vol/users 1048576K - - - -

 

=====

They show up in System Manger 3.1

Screen Shot 2015-02-17 at 6.04.48 PM.png

 

=====

They DO NOT show up in OCUM 5.2 even though I've done [Refresh Monitoring Samples] on Controllers, Volumes and Qtrees ??]

Screen Shot 2015-02-17 at 6.06.33 PM.png

 

=====

I user SQLWorkbench on the storage.user_quota table and see nothing. Looks like an empty table (after I've done Acquire Now)

Screen Shot 2015-02-17 at 6.08.17 PM.png

 

=====

=====

 

So is my problem that OCUM 5.2 is not polling the user_quotas ... and if so, why not?

 

 

korns

I'll answer my own question: in WFA 2.2 (and later I presume) each Dictionary in the Designer tab has a "Acquistion Enabled" attribute. Just view the Dictionarys, find the 'User_Quota' dictionary which will show as Acquistion Enabled: false ... right-click and pick Enable Acquistion. I'm not sure if it was required, but I did a 

[ Reset Scheme ] on existing data sources and then 'Acquire Now' and then had a valid storage.user_quota.

 

NOTE: the above is talking about 7-Mode. The cm_storage.Quota_Policy and Quota_Rule say "Not Applicable" under "Acquistion Enabled" (WFA 2.2 and 3.0RC1) which I interpret to mean not supported, or not polled through/via OCUM

NetappA051713

hi Shailaja,

many thanks, looks / works fine right now ..

regards

jens

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public