Active IQ Unified Manager Discussions

"dfm perf data retrieve" gives error

HASMIK_HAYRAPETYAN

Hi all,

I am using "dfm perf data retrieve" command to retrieve performance data from DFM server for NetApp objects but for some metrics I get following error:

C:\Windows\system32>dfm perf data retrieve -o 131 -C cifs:node:cifs_latency -d 300

Error: No instances found for object type "cifs:node". The specified counter is "cifs:node:cifs_latency" and host name is cluster-hh-01.

Why I get this error for some metrics?

I searched for information about this but couldn't find any, so if you could provide any link or help, that would be great.

Regards,

Hasmik

5 REPLIES 5

HASMIK_HAYRAPETYAN

It's strange, but I don't get cifs:node group at all, why?

HASMIK_HAYRAPETYAN

This is cluster mode, and I make call for cluster-node, not for vserver and still get the same error.

what do you get when you type "dfm perf data list"?  the 2nd column of the output for cifs:node should tell you which host DFM is collecting cifs:node data for. 

JGPSHNTAP

Is this for cMode or 7-mode?  I can only speak for 7-mode.  -o (filername)

That will do the trick

rmatsumoto

I get that message when I point it to a vserver.  You need to point it to either the cluster or the node within the cluster. 

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public