Active IQ and AutoSupport Discussions

How to bind Autosupport traffic to a specific interface only?

neves_jacques

Hi,

I've got a FAS2220 running 8.1.1 with the following network configuration (here below /etc/rc file):

---------------------------------------------

hostname xxxx

ifgrp create lacp MultiTrunk -b ip e0a e0b e0c e0d

vlan create MultiTrunk 85

ifconfig MultiTrunk `hostname`-MultiTrunk netmask 255.255.0.0 mtusize 9000 partner MultiTrunk

ifconfig MultiTrunk-85 `hostname`-MultiTrunk-85 netmask 255.255.255.0 mtusize 9000 partner MultiTrunk-85

route add default 172.16.1.250          1

routed on

options dns.domainname xxxx.yyy

otions dns.enable on

otions nis.enable off

savecore

---------------------------------------------

The autosupport traffic is using the interface MultiTrunk-85 (network 192.168.85 /24 == IP_SAN VLAN) not the default interface MultiTrunk (with default gateway 172.16.1.250).

I do wish to bind the autosupport traffic on the MultiTrunk interface (network 172.16 /16  == Production VLAN).

Any ideas?

Thanks in advance,

JNV

7 REPLIES 7

aborzenkov

What is IP address of default mailhost? Please show “netstat -rn” output.

neves_jacques

Hi,

The default mailhost is on a different VLAN (192.168.132.xx).

Regards,

JNV

aborzenkov

Please show output of “netstat -rn” and “ifconfig -a”. Network questions cannot be answered based on XX.

neves_jacques

Mailhost: 192.168.132.70


Here below netstat -rn:

----------------------------------------------

Destination      Gateway            Flags     Refs     Use  Interface

default          172.16.1.250       UGS         0        2  MultiTrunk

127              127.0.0.1          UGS         0        0  lo

127.0.0.1        127.0.0.1          UH          1        0  lo

127.0.10.1       127.0.20.1         UHS         2      336  losk

127.0.20.1       127.0.20.1         UH          0        0  losk

172.16           link#10            UC          0        0  MultiTrunk

172.16.10.1      0:1b:78:97:c1:c6   UHL         0        8  MultiTrunk

172.16.10.3      0:1b:78:99:8f:2c   UHL         0        9  MultiTrunk

172.16.10.5      0:1a:4b:ef:ad:9c   UHL         0        8  MultiTrunk

172.16.10.6      1c:c1:de:73:65:9c  UHL         0        8  MultiTrunk

172.16.10.30     0:15:5d:a:1:4      UHL         0       50  MultiTrunk

172.16.10.31     0:15:5d:a:5:5      UHL         0      312  MultiTrunk

172.16.10.110    0:15:5d:a:3:3      UHL         1        0  MultiTrunk

172.16.10.150    2:bf:ac:10:a:96    UHL         0     1471  MultiTrunk

172.16.255.255   ff:ff:ff:ff:ff:ff  UHL         0      220  MultiTrunk

192.168.85       link#11            UC          0        0  MultiTrunk-85

192.168.85.15    2:a0:98:30:58:78   UHL         2        1  lo

192.168.85.255   ff:ff:ff:ff:ff:ff  UHL         0      162  MultiTrunk-85

----------------------------------------------

here the /etc/hosts

127.0.0.1localhost
172.16.10.53gueusegueuse-MultiTrunk
192.168.85.15gueuse-ipsangueuse-MultiTrunk-85
172.16.10.54hapkin
192.168.85.16hapkin-ipsan

aborzenkov

According to this packages for 192.168.132.70 should be using MultiTrunk. Where do you see that it is using MultiTrunk-85?

neves_jacques

On the firewall, we do see SMTP traffic from MultiTrunk-85...

If I put the MultiTrunk-85 down only then Autosupport is using MultiTrunk.

Strange ;-(

Here is below "ifconfig -a":

ifconfig -a

e0a: flags=0x89f0c867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 9000

        ether 02:a0:98:30:58:78 (auto-1000t-fd-up) flowcontrol full

        trunked MultiTrunk

e0b: flags=0x89f0c867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 9000

        ether 02:a0:98:30:58:78 (auto-1000t-fd-up) flowcontrol full

        trunked MultiTrunk

e0c: flags=0x89f0c867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 9000

        ether 02:a0:98:30:58:78 (auto-1000t-fd-up) flowcontrol full

        trunked MultiTrunk

e0d: flags=0x89f0c867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 9000

        ether 02:a0:98:30:58:78 (auto-1000t-fd-up) flowcontrol full

        trunked MultiTrunk

e0M: flags=0x2b0c866<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,MGMT_PORT> mtu 1500

        ether 00:a0:98:30:58:7d (auto-100tx-fd-up) flowcontrol full

e0P: flags=0x2b4c867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM,ACP_PORT> mtu 1500 PRIVATE

        inet 192.168.2.147 netmask 0xfffffc00 broadcast 192.168.3.255 noddns

        ether 00:a0:98:30:58:7c (auto-100tx-fd-up) flowcontrol full

lo: flags=0x1b48049<UP,LOOPBACK,RUNNING,MULTICAST,TCPCKSUM> mtu 8160

        inet 127.0.0.1 netmask 0xff000000 broadcast 127.0.0.1

        ether 00:00:00:00:00:00 (VIA Provider)

losk: flags=0x40a400c9<UP,LOOPBACK,RUNNING> mtu 9188

        inet 127.0.20.1 netmask 0xff000000 broadcast 127.0.20.1

MultiTrunk: flags=0xa2f4c863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 9000

        inet 172.16.10.53 netmask 0xffff0000 broadcast 172.16.255.255

        partner MultiTrunk (not in use)

        ether 02:a0:98:30:58:78 (Enabled interface groups)

MultiTrunk-85: flags=0x2b4c863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 9000

        inet 192.168.85.15 netmask 0xffffff00 broadcast 192.168.85.255

        partner MultiTrunk-85 (not in use)

        ether 02:a0:98:30:58:78 (Enabled interface groups)

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public