Active IQ and AutoSupport Discussions

NDU (Non Disruptive Upgrade) is Disruptive - at least for me!


I am trying to upgrade my cluster on 8.0.2 to 8.1.RC3. Here is the procedure I followed:

  • Ran command on both of the nodes at the same time: FilerA/B> software upgrade <HTML_LINK> -r
  • Ran the following on both of the nodes: FilerA/B> download
  • From Node B I took over node A: FilerB> cf takeover
  • From Node B I gave back: FilerB> cf giveback -f
  • From node A tried to takeover B and it throws the following message on me:

FilerA> cf status

FilerB is up, takeover disabled because of reason (version mismatch)

FilerA has disabled takeover by FilerB (version mismatch)

        NVRAM TOC: Local 21 Partner 23

        WAFL FSInfo: Local 21057 Partner 22331

        WAFL log: Local 280 Partner 334

        RAID: Local 10 Partner 11

        RAID NVRAM: Local 27 Partner 33

Interconnect status: up.


Appreciate your inputs in advance!



It helps to read documentation before doing such major task. Upgrade and Revert Guide explains how to perform major version upgrades. In this case you need to do "cf takeover -n" and manually halt another filer.


It would help even more to have a single document with all the upgrade information inside, instead of multiple documents and a 150 pages upgrade guide !

Nevertheless, your comment was very helpful, and allowed me to complete my MC upgrade. Thanks a lot aborzenkov !


Might I suggest that you use the Upgrade Advisor tool that is part of AutoSupport on the website next time.  It will build you a step by step document.


I actually tried to at that time, but failed to generate the upgrade plan, and failed to go return to Upgrade Advisor afterwards.

The whole My AutoSupport website feels pretty awkward to me actually.

Risks and warnings keep poping up, disapearing and coming back.

I can't view half of my systems, even though I tried to re-register them correctly with support multiples times.

And it's outrageously slow connecting from France.

Anyway, I went for a new upgrade yesterday (8.1.2P4, for all the SMB2 fixes), and managed to get the upgrade plan out.

There were some useful directions in there indeed, so thanks for heading me back to it.


Perhaps you could update the status here to " answered".



I would, but I'm not the one who started this discussion (i.e. I can't do this).

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner