Active IQ and AutoSupport Discussions

Reallocate schedule

igor

Hello 2 all!

I've set up reallocation jobs to run against a test LUN, by  settings the threshold limit to 4 and establishing a twice-a-week schedule -  at 11PM on Sundays and Wednesdays:

          reallocate start -t 4 -p /vol/TEST/test.lun
          reallocate schedule -s "0 23 * 3,0" /vol/TEST/test.lun

I  had expected the reallocation (optimization) process to commence  automatically once the threshold is reached, but it doesn't.

I only keep  getting system messages in my Autosupport, advising me to run  reallocate:

Wed Dec 29 23:00:00 CET [wafl.scan.start:info]: Starting WAFL layout measurement on volume TEST.
Wed Dec 29 23:10:19 CET [wafl.reallocate.check.highAdvise:info]: Allocation check on '/vol/TEST/test.lun' is 4, hotspot 19 (threshold 4), consider running reallocate.

Sun Jan  2 23:00:00 CET [wafl.scan.start:info]: Starting WAFL layout measurement on volume TEST.
Sun Jan  2 23:10:16 CET [wafl.reallocate.check.highAdvise:info]: Allocation check on '/vol/TEST/test.lun' is 5, hotspot 19 (threshold 4), consider running reallocate.

Surely this should've been done automatically by now?

Cheers,

Igor

9 REPLIES 9

merick

Hello, I know this is an old thread, but is it possible there was a measurement scan done on the volume initially? I have a feeling the scheduled reallocation is doing a "measure only" scan.

"reallocate status -v" will show the flags for the reallocation. If you see something like this:

Flags: whole_vol,measure_only,repeat,keep_vvbn

That indicates it will only do a measurement regardless of the threshold set. The output should look like this:

Flags: whole_vol,maybe_realloc,repeat

Thanks,

Erick

cfizz34

If I am seeing this 'Flags: measure_only,repeat' <What did I do wrong when I set up my schedule and how can I correct it?

tutututu01

Hi All,

no answer for this?

No documented procedure for a secure way of 'measure' and 'start' ?

Regards,

Gwenael

chriszurich

I'm guessing this may be a case where the threshold specified (4) must exceed the current threshold of the volume being queried.  In your case it sounds like the volume has a current optimization level of 4 which matches/equals your optimization threshold.  To test this theory set the reallocate threshold to 3 and see if the reallocate job runs against the volume.  If it does then this would indicate that my theory is correct.

You could also add the -n option to have it skip checking the threshold or simply remove the -t option.

igor

I thought so too... But as you can see In the second line, the threshold has already been exceeded (5) and still nothing happened.

Thanks for the alternatives provided Chris, however I would still like to utilize threshold limits since it's an entrey level system with other workloads going on around the clock. I would like to avoid increasing CPU load and disk utilization unnecessarily. (wouldn't we all?:)  I only wish someone could tell me what went wrong.

chriszurich

Woops, looks like I didn't catch that second line.  Yeah, you definitely have a valid point.  Just out of curiosity what version of Data ONTAP are you running including release pack?

igor

DOT 7.3.4.

P.S. Is there a TR document for reallocation available? There's nothing on NOW.


radek_kubka

Yeah, awesome question - the answer is still "no" from what I know

Have you seen this thread though?

http://communities.netapp.com/message/20969#20969

Regards,
Radek

igor

Yes. Intense discussion about many reallocation aspects.   Threw in my question as well, but no reply. Pitty.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

Public