Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Ask The Experts

7mode - autosupport failure

MohamedShehata

hello all,

we have a 7mode box that sometimes fails to transmit the autosupport via SMTP,  i was able to locate the below from the log files, can someone please help to identify the issue noting many of the attempts are successful but only few attempts fails, we need to understant the root cause....

<asup:ROW col_time_us="1579168889071204">
<node>NodeName</node>
<seq-num>5125</seq-num>
<destination>smtp</destination>
<trigger>callhome.client.app.err</trigger>
<last-update>1/14/2020 10:54:00</last-update>
<status>transmission-failed</status>
<attempt-count>10</attempt-count>
<subject>CLIENT APP ERROR Backup: SME Version 7.1: (111) on EXDRUEARTOP007: SnapManager for Exchange online backup failed. (Exchange 15.0.1473.3) Error code: 0xc00413ca</subject>
<uri>mailto:autosupport@netapp.com,nas.alerts@company.com,utkarsh.singh@company.com</uri>
<error>Login denied</error>
<generated-on>1/14/2020 10:08:33</generated-on>
</asup:ROW>

2 REPLIES 2

Ontapforrum

Hi,

 

Using this tool, you can identify the meaning of that error:
https://mysupport.netapp.com/eservice/ems

 

This what it says:
EMS Identifier callhome.client.app.err
Severity ERR

Description : This message occurs when a remote client accesses the node using
Manage ONTAP and triggers an event using the ems-autosupport-log API
call with "auto-support" field set to "true". If your system is configured to do
so, it generates and transmits an AutoSupport (or 'call home') message to
NetApp Service and Support and to the configured destinations. Successful
delivery of an AutoSupport message significantly improves problem
determination and resolution.

 

Corrective Action : Identify and resolve the issue on the "remote client" that is using the Manage
ONTAP API to trigger this event. If you need assistance, contact technical support.


Remote client is : EXDRUEARTOP007 (SnapManager for Exchange) and API it's using to generate autosupport : api-ems-autosupport-log


My advise would be:
1) Log on to filer and check the failed attempts:
Run the following to verify the failed autosupport on 14th.
filer> autosupport history show

2) check logs;
filer>rdfile /etc/messages

3) login to EXDRUEARTOP007 and check the application logs (This is the root cause as per the EMS Correction Action), do you see any communication errors that happended between this machine and the EXDRUEARTOP007 ?

Thanks!

paul_stejskal

Generally you have to enable anonymous SMTP on the Exchange server, assuming Exchange. This is a bit dated so the boxes are in a different spot, but the core functionality is the same: https://kb.netapp.com/app/answers/answer_view/a_id/1032277/loc/en_US.

 

HTTPS is recommended to provide security however. support.netapp.com ports 80 and 443 generally only have to be open from the interface that has node management port built in. (hint: it's the one when you run hostname in /etc/rc)

 

You should find a log on the mail server as the prior poster mentioned.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public