Ask The Experts

Highlighted

After upgrade to 9.3P9 connections to API via Perl is not possible (HTTP 400 Bad Request)

Hi,

 

after upgrading my FAS8020 from ONTAP 9.1x to 9.3P9 connections to the API via perl are not working.

 

For monitoring my Filer I'm using Nagios on CentOS 6.9 in combination with "check_netapp_ontap.pl".

After the ONTAP upgrade i also updated the SDK to 9.3 on my Nagios box.

 

When i'm no trying to get a connection to the API I'll get the following error

“Failed test query: Server returned HTTP Error: 400 Bad Request”

I'm recieving the same error when i'm try to connect via "apitest.pl" of the SDK

[xxxx@venus02 perl5]# perl /usr/local/src/netapp-manageability-sdk-9.3/src/sample/Data_ONTAP/Perl/apitest.pl netapp-host.fqdn <API-User> <Password> system-get-version

OUTPUT:
<results status="failed" reason="Server returned HTTP Error: 400 Bad" errno="13001"></results>

 

 I allready changed the cluser-name and the node-names to names without _ or -

But it changed nothing on the behavoir. 

I opened a ticket at NetApp Support and they told me I should try the ZExplorer Tool, which is also a part of the SDK, and test if I can connect to the API.
And yes, it's working. With ZExplorer I can connect to API and execute "system-get-version" for example.
I also got some commands from Support to restart the Webserver which is responsible for the API on my FAS8020, but it doesn't helped.

So, now I'm here, becuase the offical Answer from NetApp is "

For now the Netapp Manageability SDK and custom scripts are supported only in the community and not by Netapp Technical support" ....
YAY..... But at least the technican I spooke with is trying to reproduce this in his lab. But this takes "some" time.

 

Anyone here who can help me?? 🙂


Thanks,
Marcel

Check out the KB!
Knowledge Base
All Community Forums