Ask The Experts

Cannot Assign/Remove Owner from Swapped Disks


I am attempting to reassign ownership from swapped disks from another shelf of the same model Netapp. The one the I am swapping from is offline so I have not been able to fail them or release their ownership from that end.


The disks will not give up their ownership in the new Netapp. Their status is showing as Unknown.

When I ask for ownership they still show their old ownership and homeid.


I am using advanced privilege.

I have attempted the following:


storage disk removeowner -disk *.*.*

without options it gives me this result - Error: command failed: Failed to remove the owner of disk "*.*.*". Reason: Cannot remove owner of disk "*.*.*" because it is shared.


storage disk removeowner -disk *.*.* with options -root, -data, -data1, -data2 & -force true

all of these option gave me the same error: Error: command failed: Internal error. Unable to determine the sharing method for disk "*.*.*".


storage disk assign -disk *.*.* -owner node (with options) -root, -data, -data1, -data2 true -force true

This one confuses me more: Error: command failed: Failed to get name for the local node


Since these came from another Netapp I decided to use their previous homeid and try to reassign them and....


storage disk reassign -homeid **** -newhomeid ***** -force true

Error: command failed: Disk reassign failed. Reason: disk reassign is only allowed during takeover in advanced mode. (This reason sucked because manually doing this would have solved my problem immediately, but no)


I am seriously confused as to why I cannot get these disks to change their ownership.I have tried every command that is out there and they just won't change.



Re: Cannot Assign/Remove Owner from Swapped Disks




Try this procedure at your own risk:


Have done this in the past and worked.


After that you may need to remove any foreign aggregate in order to use the disks.




All Community Forums