Ask The Experts

Highlighted

False disk info after replacing broken disk

After I've removed and replaced a broken disk in our system (NetApp Release 8.3.2P9) I still see information about the removed disk.  The disk ID  2.11.4 still gives the status "failed" en it even shows the serial number of the removed disk. An unassigned disk shows up and by the serial number I have verified that this is indeed the replacement disk in shelf 11, bay 4.

I've tried a number of things like eg. to unfail the disk 2.11.4 with the result "Disk "2.11.4" does not exist". I can't seem to find a way around this issue and untill now so doesn't Arrow NetApp support where we have an open support case. Any help would be appriciated.

11 REPLIES 11
Highlighted

Re: False disk info after replacing broken disk

Relese 8.3.x, means this is cDOT.

 

Disk does not exist error is normally reported when the disk's ownership is not known to the Node.

 

What does the disk '2.11.4' shows up as when you run this command: 'unknown' ?

cluster01::> storage disk show -shelf 11


Go to the node shell of the node that has the disk attached, run this command:


cluster01::> node run -node node-xx
Type 'exit' or 'Ctrl-D' to return to the CLI
node-xx> disk assign 2.11.4 -s unowned -f

Highlighted

Re: False disk info after replacing broken disk

Thanks for your swift reply.

First, the information about the broken disk disappeared once I reseated the physical disk, so the problem that is remaining is that of an unassigned disk.

 

When running storage disk show -shelf 11, disk 2.11.4 is missing :

2.11.3   836.9GB   11   3   SAS   aggregate BL_NF0011_DATA1   BL-NF0011
2.11.5   836.9GB   11   5   SAS   aggregate BL_NF0011_DATA1   BL-NF0011

Any command with disk id 2.11.4 fails because it can't be found.

I found out by checking the serial number that the disk in Shelf 11, bay 4 is an unassigned disk with the name :

BL-NF0011:switch_V2_2:6.126L83

but assigning it to node BL-NF0011 fails because "redundancy errors were detected" or maybe it would work if I use the force option ? The other thing I haven't come across earlier is the disk id. In the past when I replaced a broken disk, the new one alsways came up as eg. 2.11.4 and when I execute "storage disk show BL-NF0011:switch_V2_2:6.126L83" the  Stack ID/Shelf/Bay: - / - / - information stays empty so I'm puzzled how I can find the physical location of a disk with such a name.

Highlighted

Re: False disk info after replacing broken disk

Hi,

 

Can I know which FAS platform is this ?

 

Also, the output of : disk show -v

 

Do you see anything in :

::> event log show -node xx

 

Highlighted

Re: False disk info after replacing broken disk

Also, try force option:

 

Note: Don't use this format : 2.11.4, instead of '2' use the channel ID: whether it is '0a', '0b' etc...in the front, whatever is in your case.


priv set advanced
disk assign xx.11.4 -f


You can find the channel ID via:
disk show -v
environment status shelf [look for channel ID / SAS Port]

 

If that dosent work, try this: [You can find sysid from from output of 'sysconfig -a' command.

priv set advanced
disk reassign -s -d <sysid>

Highlighted

Re: False disk info after replacing broken disk

FAS8020-R6

 

With disk show -v the disk shows up as :

BL-NF0011:switch_V2_2:6.126L83
NONE WFK2D46K -
Not Owned

 

the only thing I can find with event log show -node BL-NF0011 and which appears regularly :

 

9/18/2019 14:00:02 BL-NF0011 INFORMATIONAL unowned.disk.reminder: 1 disks are currently unowned. Use the "disk assign" command to assign the disks to a filer.

 

Highlighted

Re: False disk info after replacing broken disk

Try the commands  sent in last reply.

Highlighted

Re: False disk info after replacing broken disk

Thanks for your help.

finally managed to assign the disk with the -force option.

storage disk assign -disk xxxxxxxxx:switch_V2_2:6.126L83 -owner xxxxxxxxx -force

 

Normally I would see the disk like 2.11.4 (which tells me instantly the physical position of the disk), now I'm stuck with the longer name and when I execute :

BL-VNF0001::> storage disk show -disk xxxxxxxxx:switch_V2_2:6.126L83
Disk: xxxxxxxx:switch_V2_2:6.126L83
Container Type: spare
Stack ID/Shelf/Bay: - / - / -

there is no information about the physical position. And when I execute : storage disk show -shelf 11

there's no sign of the disk either.

So how can I find out the shelf and bay location of this disk when it fails ?

 

Kind regards

 

Highlighted

Re: False disk info after replacing broken disk

Thanks for the update, I am still very curious about the disk type (It looks odd) I haven't see it before.

 

Can you check if you have DQP (Disk Qualification Package) installed ?

 

::> node run -node NODE-xx
node> rdfile /etc/qual_devices_v3

 

Do you see any output?

If no ouput that means - DQP is not installed.


If you see output: What is the date at the bottom ? something like this.
#
# Datecode: 20180205
#

Highlighted

Re: False disk info after replacing broken disk

Hi,

I do get (a lot of) output > # Datecode: 20150517

Highlighted

Re: False disk info after replacing broken disk

Hi,

 

That's more than 4 years old.

 

# Datecode: 20150517

# Datecode: yyyymmdd

 

Can you put the latest one in there.

https://mysupport.netapp.com/NOW/download/tools/diskqual/

 

No harm in updating it b'cos totally non-disruptive, it's just a flat file, you can do this anytime, it has no bearing on performance of system.

 

We need to rule out anything that could have caused that, so let's do that and if it  still dosent fix then I guess you will need to get the NetApp email/phone support involved.

Highlighted

Re: False disk info after replacing broken disk

@Ronald_Nieuwenhuijs  Please see the response provided by our experts, If you need any further assitance let let us know.

 

If you think the above response solved your issue then feel free to mark it as solution so it will help someone with the same issue.

Check out the KB!
Knowledge Base
All Community Forums