Cloud Insights

Data Collector Failing

What error is this?

 

Internal error: Cannot update server (Failed to execute the http method for request https://0da44afd-4051-474e-8a1e-5ab17b9f33ed.c02.cloudinsights.netapp.com/compose/originatorUpdate/SANSCREEN/2 500 error is Internal Server Error)

 

I've been getting pretty generic 401: Not Authorized or Inventory Failed from the ONTAP Data Collector. Sometimes the Test Config succeeds and sometimes it fails to execute test command on device without re-entering the password. I can log directly into OnCommand on the FAS and all the appropriate services on the Data Collector VM appear to be running.

 

Edit: Just got another 401 error: Invalid login credentials: 401 Unauthorized.

9 REPLIES 9

Re: Data Collector Failing

Hi,

 

It's been 2 weeks for your query, but let me still ask : Are you still experiencing 500 & 401 errors on Data collector ?

 

I guess you have two queries:

1) 500 Internal error: Cannot update server [OCI ?]
2) 401 error: Invalid login credentials: 401 Unauthorized [Data Collector]


For the 1st query, are you using OCI for the collection, if so what version is that ?

 

For the 2nd query, could you ensure the account has sufficient privileges.

Error code in the following doc, indicates an issue with ' “Insufficient privileges” or “not authorized for this command”.

Check: privileges/permissions

 

NetApp ONTAP Data Management Software Data Collector:
https://docs.netapp.com/us-en/cloudinsights/task_dc_na_cdot.html#terminology

 

Note: You can even open a ticket with NetApp if the issue is becoming a show-stopper.

 

Thanks!

Re: Data Collector Failing

I'm running CI. I checked my credentials first thing and the correct permissions are set, I can log directly into the FAS as an admin. I had the lab admin elevate my permissions to full admin to double check.

The first image below is the error. The second is after I enter in the password to test and the third is after I run the test again with no changes. Even after that, it's not sending data. I do get information from ActiveIQ.

As near as I can tell, the data collector service is running on the VM in the lab there is also an Aquisition Unit running on the same VM and it reported OK 13 hours ago.

Could this be related to my license level? At the moment, it's at Basic until I can get my final lab license.

 

Thanks!

 

Annotation 2019-11-28 111255 1.jpgAnnotation 2019-11-28 111255 2.jpgAnnotation 2019-11-28 111255 3.jpg

Re: Data Collector Failing

Thanks for clearing that for me.

 

I have worked with OCI before , but this is new for me as well. So, I tried to look up information and found some useful links:

 

Your guess is right, as you have a Basic License : You can only monitor NetApp, as per the pricing model below.


NetApp Cloud Insights: A New Way to Monitor Your Cloud Infrastructure
https://www.netapp.com/us/media/wp-cloud-insights.pdf

 

Editions & Pricing
https://cloud.netapp.com/cloud-insights:

 

BASIC : Free
Infrastructure & Storage Metrics = NetApp Only [Multi-vendor not available]

 

STANDARD : $
Infrastructure & Storage Metrics : Multi-vendor

 

PREMIUM : $$
Infrastructure & Storage Metrics : Multi-vendor along with advanced reporting & auditing.

Re: Data Collector Failing

Yep, I'm very familiar with that.  The device I'm having trouble monitoring is an AF300, so it's NetApp.

Re: Data Collector Failing

Glad to know you are famililar with that, it will help you in troubleshooting as well.


The error clearly states : ZAPI communication failed : Unauthorized.

 

Question:
Does the user (svc-cloud-oci) have the "http" and "ontapi" application permissions to access storage systems ?

 

Suggestion:
Log onto the NetApp and check what 'Application' has been assigned the the username that is being used to authenticate by running the following command:

::> security login show

 

Thanks!

Re: Data Collector Failing

Yep, I'm allowed http & ontapi.

And now I'm getting data, but the Data Collector is still showing "All Failed" with the same 401 error. This time, it says it last worked 14 hours ago.

 

Could it be an HTTP issue between CI and the data collector?

Re: Data Collector Failing

Could you share the output of this command:
::> security login show

 

We should see some traces here:
::> event log show

::> audit log show

Re: Data Collector Failing

I'm going to go have a drink, it's cleared up and is collecting data. The only changes I've made (that I can tell) is to drop the inventory interval to 10 minutes and the performance to 5.

 

Thanks for your help, I do appreciate it.

Re: Data Collector Failing

No worries, thanks for that information. I appreciate it.

 

Thanks!

Forums