EF/E-Series, SANtricity, and Related Plug-ins

E-Series SANtricity Simulator 11.50 - discovery yields nothing (Win 10)

elementx

Win 10 x64 and SANtricity simulator for v11.50:

- I start it with all_restart.bat

- I login to the one running with the 127.0.0.1 address, set a new password

- Then from the other tab (with localhost address) I try to discover and nothing happens 

 

- WebAPI error:

 

15:09:56.707 INFO [jetty-87] c.n.e.a.r.servants.DiscoveryImpl - {"user":"admin","resource":"/devmgr/v2/discovery","remoteAddress":"0:0:0:0:0:0:0:1","method":"POST","query":null,"status":"202","executionTime":"21"}
15:09:57.032 WARN [pool-16-thread-1] c.n.e.a.d.SymbolDiscoveryCallback - An exception occurred during discovery for 127.0.0.1
org.apache.http.HttpException: Unexpected SYMbol http tunnel status code 404 from host /127.0.0.1:8443
at devmgr.api.rpc.HttpRpcClient$2.completed(HttpRpcClient.java:367)
at devmgr.api.rpc.HttpRpcClient$2.completed(HttpRpcClient.java:360)
at org.apache.http.concurrent.BasicFuture.completed(BasicFuture.java:123)
at org.apache.http.impl.nio.client.DefaultClientExchangeHandlerImpl.responseCompleted(DefaultClientExchangeHandlerImpl.java:181)
at org.apache.http.nio.protocol.HttpAsyncRequestExecutor.processResponse(HttpAsyncRequestExecutor.java:437)
at org.apache.http.nio.protocol.HttpAsyncRequestExecutor.inputReady(HttpAsyncRequestExecutor.java:327)
at org.apache.http.impl.nio.DefaultNHttpClientConnection.consumeInput(DefaultNHttpClientConnection.java:265)
at org.apache.http.impl.nio.client.InternalIODispatch.onInputReady(InternalIODispatch.java:81)
at org.apache.http.impl.nio.client.InternalIODispatch.onInputReady(InternalIODispatch.java:39)
at org.apache.http.impl.nio.reactor.AbstractIODispatch.inputReady(AbstractIODispatch.java:121)
at org.apache.http.impl.nio.reactor.BaseIOReactor.readable(BaseIOReactor.java:162)
at org.apache.http.impl.nio.reactor.AbstractIOReactor.processEvent(AbstractIOReactor.java:337)
at org.apache.http.impl.nio.reactor.AbstractIOReactor.processEvents(AbstractIOReactor.java:315)
at org.apache.http.impl.nio.reactor.AbstractIOReactor.execute(AbstractIOReactor.java:276)
at org.apache.http.impl.nio.reactor.BaseIOReactor.execute(BaseIOReactor.java:104)
at org.apache.http.impl.nio.reactor.AbstractMultiworkerIOReactor$Worker.run(AbstractMultiworkerIOReactor.java:588)
at java.lang.Thread.run(Thread.java:748)
15:10:02.255 INFO [jetty-85] c.n.e.a.r.servants.DiscoveryImpl - {"user":"admin","resource":"/devmgr/v2/discovery","remoteAddress":"0:0:0:0:0:0:0:1","method":"GET","query":"excludeManagedSystems=true&requestId=1","status":"200","executionTime":"0"}
15:10:02.718 INFO [MultiDeviceManager-2] c.n.e.a.d.connection.FTClient - Device 00000000-0000-0000-0000-000000000000: Retries exceeded for Proc getChangeState, last error: Unable to connect to the storage system

 

- Trace-Simulator - minor bug with the inability to gracefully handle disabled IPV6, otherwise OK.

 

2018-09-23 15:08:30.519 [Thread-7] ERROR devmgr.versioned.jrpc.RPCServer.startUDP(RPCServer.java:182) - Failed to join group
java.net.SocketException: Can't join an IPv6 group on a IPv4 socket
at java.net.TwoStacksPlainDatagramSocketImpl.join(Native Method) ~[?:1.8.0_181]
at java.net.AbstractPlainDatagramSocketImpl.join(AbstractPlainDatagramSocketImpl.java:178) ~[?:1.8.0_181]
at java.net.MulticastSocket.joinGroup(MulticastSocket.java:323) ~[?:1.8.0_181]
at devmgr.versioned.jrpc.RPCServer.startUDP(RPCServer.java:178) [symbol-core-11.50.6.22.jar:?]
at devmgr.simulator.DiscoveryServer.<init>(DiscoveryServer.java:75) [simulator-11.50.0G0G.0090.jar:?]
at devmgr.simulator.ControllerRPCServer.run(ControllerRPCServer.java:116) [simulator-11.50.0G0G.0090.jar:?]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_181]
2018-09-23 15:08:30.527 [Thread-7] INFO devmgr.simulator.DiscoveryServer.<init>(DiscoveryServer.java:76) - DiscoveryServer - started on IP address /127.0.0.1:2464
2018-09-23 15:08:30.572 [devmgr.versioned.jrpc.RPCServer$UDPThread[2464]] INFO devmgr.versioned.jrpc.RPCServer$UDPThread.run(RPCServer.java:867) - Server UDP thread running on port 2464

 

- Weird stuff in SAM Web Server log - this is from the first start after a reboot, so it couldn't have been from an unclean shutdown attempt before:

 

INFO: Started Message Server with in-memory connector
Sep 23, 2018 3:08:33 PM com.loem.aa.webserver.server.WebServer start
INFO: Unable to start message server
java.io.IOException: Failed to bind to server socket: nio://0.0.0.0:61616 due to: java.net.BindException: Address already in use: bind
at org.apache.activemq.util.IOExceptionSupport.create(IOExceptionSupport.java:34)
at org.apache.activemq.transport.tcp.TcpTransportServer.bind(TcpTransportServer.java:144)
at org.apache.activemq.transport.tcp.TcpTransportFactory.doBind(TcpTransportFactory.java:62)
at org.apache.activemq.transport.TransportFactorySupport.bind(TransportFactorySupport.java:40)
at org.apache.activemq.broker.BrokerService.createTransportConnector(BrokerService.java:2520)
at org.apache.activemq.broker.BrokerService.addConnector(BrokerService.java:339)
at org.apache.activemq.broker.BrokerService.addConnector(BrokerService.java:329)
at com.loem.aa.webserver.server.MessageServer.start(MessageServer.java:90)
at com.loem.aa.webserver.server.WebServer.start(WebServer.java:740)
at com.loem.aa.webserver.Main.main(Main.java:79)
Caused by: java.net.BindException: Address already in use: bind
at sun.nio.ch.Net.bind0(Native Method)
at sun.nio.ch.Net.bind(Net.java:433)
at sun.nio.ch.Net.bind(Net.java:425)
at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
at org.apache.activemq.transport.nio.NIOTransportFactory$2.createServerSocket(NIOTransportFactory.java:83)
at org.apache.activemq.transport.tcp.TcpTransportServer.bind(TcpTransportServer.java:141)
... 8 more

java.io.IOException: Failed to bind to server socket: nio://0.0.0.0:61616 due to: java.net.BindException: Address already in use: bind
at org.apache.activemq.util.IOExceptionSupport.create(IOExceptionSupport.java:34)
at org.apache.activemq.transport.tcp.TcpTransportServer.bind(TcpTransportServer.java:144)
at org.apache.activemq.transport.tcp.TcpTransportFactory.doBind(TcpTransportFactory.java:62)
at org.apache.activemq.transport.TransportFactorySupport.bind(TransportFactorySupport.java:40)
at org.apache.activemq.broker.BrokerService.createTransportConnector(BrokerService.java:2520)
at org.apache.activemq.broker.BrokerService.addConnector(BrokerService.java:339)
at org.apache.activemq.broker.BrokerService.addConnector(BrokerService.java:329)
at com.loem.aa.webserver.server.MessageServer.start(MessageServer.java:90)
at com.loem.aa.webserver.server.WebServer.start(WebServer.java:740)
at com.loem.aa.webserver.Main.main(Main.java:79)
Caused by: java.net.BindException: Address already in use: bind
at sun.nio.ch.Net.bind0(Native Method)
at sun.nio.ch.Net.bind(Net.java:433)
at sun.nio.ch.Net.bind(Net.java:425)
at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
at org.apache.activemq.transport.nio.NIOTransportFactory$2.createServerSocket(NIOTransportFactory.java:83)
at org.apache.activemq.transport.tcp.TcpTransportServer.bind(TcpTransportServer.java:141)
... 8 more
Sep 23, 2018 3:08:33 PM com.loem.aa.webserver.server.WebServer doShutdown
INFO: Starting Shutdown
Sep 23, 2018 3:08:33 PM com.loem.aa.webserver.server.WebServer doShutdown
INFO: Starting Shutdown
Sep 23, 2018 3:08:33 PM com.loem.aa.webserver.server.WebServer doShutdown
INFO: Error on shutdown
java.lang.NullPointerException
at com.loem.aa.webserver.server.WebServer.doShutdown(WebServer.java:349)
at com.loem.aa.webserver.server.WebServer.lambda$addShutdownHook$1(WebServer.java:268)
at java.lang.Thread.run(Thread.java:748)

java.lang.NullPointerException
at com.loem.aa.webserver.server.WebServer.doShutdown(WebServer.java:349)
at com.loem.aa.webserver.server.WebServer.lambda$addShutdownHook$1(WebServer.java:268)
at java.lang.Thread.run(Thread.java:748)
Sep 23, 2018 3:08:33 PM com.loem.aa.webserver.server.WebServer doShutdown
INFO: Shutdown.
Sep 23, 2018 3:08:33 PM com.loem.aa.webserver.server.WebServer doShutdown
INFO: Shutdown.
Sep 23, 2018 3:08:33 PM com.loem.aa.webserver.server.MessageServer stop
INFO: Stopping Message Broker
SLF4J: Failed to load class "org.slf4j.impl.StaticMDCBinder".
SLF4J: Defaulting to no-operation MDCAdapter implementation.
SLF4J: See http://www.slf4j.org/codes.html#no_static_mdc_binder for further details.
Sep 23, 2018 3:08:33 PM com.loem.aa.webserver.server.MessageServer stop
INFO: Message broker stopped

 

 

 

1 ACCEPTED SOLUTION

elementx

I had to uninstall existing proxy... I didn't expect simulator uses the same port numbers... 

View solution in original post

1 REPLY 1

elementx

I had to uninstall existing proxy... I didn't expect simulator uses the same port numbers... 

View solution in original post

Announcements
Register for Insight 2021 Digital

INSIGHT 2021 Digital: Meet the Specialists 2

On October 20-22, gear up for a fully digital, totally immersive virtual experience with a downright legendary lineup of world-renowned specialists. Tune in for visionary conversations, solution deep dives, technical sessions and more.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public