General Discussion

Data ONTAP 8.x 7-Mode CIFS --forcegroup

 

We tried to user the --forcegroup options when trying to create a CIFS shared.

The  /vol/DataLog_NFS_vol volume and qtree are create with UNIX style and shared to other linux workstation.

 

cifs shares -add test123 /vol/DataLog_NFS_vol -forcegroup testgroup

 

whoever we get are getting the error:

testgroup: unknown group

 

We have this testgroup create under our linux server already.

 

May I know where is this --forcegroup  <groupname> refer too ?

 

We even tried

--forcegroup "domain\testgroup"

--forcegroup  Users

 

Nothing seems to work.

 

Please help.

 

Thanks.

 

1 REPLY

Re: Data ONTAP 8.x 7-Mode CIFS --forcegroup

Hi,

 

The group should be a group from theUnix group database of the filer, not from any Unix server you are mounting from, and not an Active Directory group.

 

In its simplest form, you should be able to add entries to /etc/group on the storage system.

By default, you only have something like this in it:

 

fas3240-tcb1*> rdfile /etc/group
daemon:*:1:

 

I believe it should also be possible to use NIS and/or LDAP to store this group information in case you need to keep track of the group <-> groupID mappings centrally.

Forums