Microsoft Virtualization Discussions

Set-NaCifs: Unable to process


Hey There,

Relatively new to the PS thing but so far I could find all the information needed for my powershell script on our flexclone environment. But, I've got one tiny issue with Set-NaCifs I couldn't find the issue.

I create a new vfiler. I connect to the vfiler...

$Credential = Get-Credential

Connect-NaController –name filername -Vfiler vfilertest –Credential $Credential

$pw = $Credential.GetNetworkCredential().Password

I create the /etc/passwd & /etc/groups....


New-NaCifsPasswordFile $pw

Then I want to run CIFS Setup via Powershell...

Set-NaCifs -CifsServer vfilertest -AuthType workgroup -SecurityStyle multiprotocol

and get this error:

Set-NaCifs : Unable to process one or more of the input values.

At line:1 char:11

+ Set-NaCifs <<<<  -CifsServer vfilertest -AuthType workgroup -SecurityStyle multiprotocol

+ CategoryInfo          : InvalidOperation: (fil-srv01-inf:NaController) [Set-NaCifs], EINVALIDINPUTERROR

+ FullyQualifiedErrorId : ApiException,DataONTAP.PowerShell.SDK.Cmdlets.Cifs.SetNaCifs

Couldn't find anything on google or on here. I have tried it with different AuthTypes and capital letter CifsServer names all leading to this same issue. Anyone ever experienced this?




Re: Set-NaCifs: Unable to process


hello, did you specify the domain parameter?, here's an sample from the cmdlet help.

Set-NaCifs -CifsServer DUNN -AuthType workgroup -SecurityStyle ntfs -Domain cifsworkgroup

View solution in original post

Re: Set-NaCifs: Unable to process


Well done, now I feel very stupid 😉

Yeah it worked of course. I forgot to add the workgroup/domain. I was abit confused by the term Domain I guess that's why I didn't include it. Makes sense tho.

Thanks a lot


Earn Rewards for Your Review!
GPI Review Banner
All Community Forums