Network Storage Protocols Discussions

CIFS problem



I'm having a bit of trouble with a new filer and was hoping someone here can help me figure it out. I have a client that has a FAS2240 running ONTAP 8.1.2 with about 5 cifs shares setup. However, users on the domain are unable to access the shares. When they try to access the shares from their widows machines (windows 7), they're prompted to authenticate with a username and password. On keying this in, they get prompted again with an error that the username/password is incorrect. I have run/re-run cifs setup on the filer about 4 times now with no luck. Still getting the same issue. They client also has another filer, FAS2040, also running 8.1.2. That filer also has cifs shares and domain users can access them perfectly fine without being prompted for credentials.

Another thing is, I'm completely unable to access the administrative shares (C$, ETC$) either. I get the same prompt for credentials. It's almost as if the filer isn't really connected to the domain. I've done a "cifs testdc" which reports all as fine and "cifs domaininfo" which reports the correct info. I can do "cifs lookup" of domain users successfully, and DNS is also configured well, as I can ping hosts on the domain via hostname successfully. Anyone come across something like this?

I even went to the extent of altering all the cifs options on the 2240 to match those on the working 2040, with no success.



Re: CIFS problem


Hi Frank,

Have you checked your DNS entries?
Did you delete the domain account for the filer and run the cifs setup again? I had the same problems and now it works


Re: CIFS problem


Hi Frank i have got exactly the same problem as you have, i suppose when you set the logging enabled you see kerberos errors.

Have you got a solution from support yet? please let me know so it saves me some time.

What is your domain version?

We have got different setup's over several customers and the 2003R2 domain vs. the 2240 ontap 8.1.2. seems to be the problem regarding CIFS

I read on some article the  "options cifs.smb2.client.enable off" setting couldt maybe bring some light in the darknes but i am not onsite at this moment and am no able to test it at this moment.

CIFS problem


Managed to solve my problem. It seems for some reason that when you run cifs setup on ONTAP 8.1.2, it does not create the "pcuser" in /etc/passwd. Windows users are mapped to this user when they try to access shares on the filer. I noticed that on the 2240s, /etc/passwd was empty. So I copied the contents from the 2040 and pasted them to the 2240, and bingo! Started working!

If you set "options cifs.trace_login" to "on" you can see it mapping the user attempting to log on to "pcuser". I had thought these user would have been created by default when you run cifs setup, but I could be wrong.

Hope that helps.

View solution in original post

Re: CIFS problem


Hi Frank , thanx for sharing your experience with me, it solved indeed my problem as well!!  It seems there is a bug in the ontap 8.1.2 when installed from scratch and first time CIFS setup.

I also didn't have the pcuser entry in the /etc/passwd file, copied it from a running environment and solved my problem 🙂

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums