ONTAP Discussions

7-Mode to CDoT Snapmirror Struggles


I have been struggling with establishing a transition SM between a 7-mode system and a cDOT system.

I have configured many others in my environment that have worked successfully and have followed the same procedures on this particular one with no success.

Any help/suggestions would be appreciated.  Here's the scenario:


Source 7-Mode system:  FAS3240, OnTAP 8.2.1  7-mode, 64bit aggregates

  • options snapmirror.access allowing IP's of Intercluster LIF's of cDOT system

Destination cDOT system:  FAS3250, OnTap 8.2.1 Cluster-mode

  • vserver peer transition is created
  • Intercluster LIF's exist
  • Volume created with type "DP"
  • Snapmirror created with type "TDP"

7-Mode /etc/messages after Snapmirror initialize:

[<hostname>:snapmirror.src.sockErr:error]: Cannot accept SnapMirror destination requests: destination connection dropped.


After MANY attempts, I decided to install the 7MTT to see what it would do:

With the 7MTT tool, I am unable to add the 7-mode system.   I get "System is unreachable" on the 7MTT side.  Nothing in /etc/messages of the 7-mode system.

The "ransition-gui.log" on the 7MTT system reports the following:

  • [c.n.t.g.s.TransitionGUIExceptionHandler: ERROR] [transition-server-thread9]: Exception: Failed to communicate with 7-Mode storage system

I have followed the 7MTT workflow troubleshooting from the knowledgebase with no success.


Any suggestions?  What am I missing?


Re: 7-Mode to CDoT Snapmirror Struggles


I would start with ping tests from 7-Mode to ALL cDOT intercluster lifs.. then net ping back from ALL cDOT intercluster lifs to 7-Mode. 7MTT is alerting about not being able to reach 7-Mode...but could be routing from cDOT to 7-Mode...


Usually it is either options snapmirror.access but you already checked that, or routing... in cDOT when you create a LIF manually, it creates the routing entry but without routes.  For example, if you run "net routing-group show" you will see the "ix.x.x.x" network, but when you type "net routing-group route show" do you see a default route for that routing group.  Often that can be the issue.  Also run "event log show" and see if anything on that end.


Do you have routes on cDOT or errors in cDOT logs?

Re: 7-Mode to CDoT Snapmirror Struggles


Thank you for the suggestions. Here's what I've uncovered so far.

I performed some testing and was able to setup 7-mode to cDOT SM relationships from other 7-mode systems to this particular cDOT system and they worked as expected, without problem.

The same entries were placed in the "options snapmirror.access" on the working, 7mode systems as the non-working system.

I confirmed that pings work in both directions, routing-groups and routes exist with default routes.

It is only this one 7-mode system that is not working.


Confirmed successful pings:

From cDOT:  network ping -lif intcl_lif -lif-owner xxxxxxx -destination "7-mode system ip" -disallow-fragmentation false -show-detail

  • Results in successful pings

From 7mode:  ping <cDot intcl lif>

  • Results in "its alive"

cDOT:  event log show

  • 12/27/2014 16:35:45 cDOT_hostname     ERROR         smc.snapmir.init.fail: Initialize from source volume '7mode_hostname:volume' to destination volume 'cDOT_SVM_hostname:volume' failed with error 'Transfer failed.'. Relationship UUID '3f4d0427-8e10-11e4-9703-123478563412'.
  • 12/27/2014 16:35:44 cDOT_hostname     ERROR         replication.dst.err: SnapMirror: destination transfer from 7mode_hostname:volume to cDOT_volume : replication transfer failed to complete.

  • 12/27/2014 16:35:44 cDOT_hostname     NOTICE        recover.abort.ROOLR: The abort event, snapmirror: Cannot Init NTM, aborting
    , is just notified.

7mode:  /etc/messages

  • Sat Dec 27 16:35:30 EST [7mode_hostname:snapmirror.src.sockErr:error]: Cannot accept SnapMirror destination requests: destination connection dropped.

  • Sat Dec 27 16:35:44 EST [7mode_hostname:replication.src.err:error]: SnapMirror: source transfer from vol3 to cDOT_hostname:volume : transfer failed.

Re: 7-Mode to CDoT Snapmirror Struggles


After pulling out most of my remaining hair, I found the problem.  It turned out to be an MTU setting on the 7-mode system.

I have a VIF (ifgrp) on this 7-mode system that consists of a 2GB LACP and a 20GB LACP combined into a single-mode VIF, favoring the 20GB.

MTU was set to 9000 on the single-mode VIF, but even though I am favoring the 20GB connection I was unable to pass packet sizes over 1500.


I set the MTU to 1500 on the main VIF and initialized the snapmirror and it worked as expected.

View solution in original post

Re: 7-Mode to CDoT Snapmirror Struggles


@tlkendall thanks a lot for your comment! I spent a few hours fighting this problem.

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums