The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

ONTAP Discussions

AIX rootvg boot issues from cDOT storage

JAK

AIX rootvg boot issues from cDOT storage

 

I am trying to resolve AIX system boot issues from the cDOT system. Here's the issue:

 

I can boot the AIX from the old IBM N-Series storage using N-Series Host Utilities Kit (HUK). Our goal is to migrate this server from the N-Series to the new cDOT system so the server is booting from the new cDOT. The AIX server doesn't see the boot device after we have uninstalled the N-Series HUK and the new HUK Ver.6 for AIX is installed. We went through various test scenarios as below:

 

Two IBM AIX Test Enviroments.

 

  • Test Environment #1:
    • Purpose:
      • Uninstall IBM N-Series HUK in favor of NetApp 6.0 HUK
    • Host/LPAR:
      • AIX 6.1 TL8 SP3
      • IBM N-Series HUK Installed.
      • Using NPIV not vSCSI via VIO Server
    • Storage:
      • SAN Boot LUN Data has already been migrated from N-Series to the following:
        • SAN Boot LUN on NetApp ClusteredONTAP 8.2 (8040/8020 HA cluster)
    • Attempted Tests:
      • Test #1: Uninstall of IBM N-Series HUK & Install of NetApp HUK:
        • 1 - Single Path created for Boot LUN from LPAR to CDOT array using assigned portset to igroup. (Only one HBA adaptor enabled on LPAR)
        • 2 - Boot off single path LUN
        • 3 - Chdev –p hdisk# -a algorithm=fail_over –a reserve_policy=single-path
        • 4 - Bootlist –m normal hdisk# (ensure boot LUN is in bootlist)
        • 5 - Remove all other devices except boot LUN.
        • 6 - Remove all N-Series MPIO drivers

Installation Summary

--------------------

Name                       Level           Part        Event       Result

-------------------------------------------------------------------------------

Ontap.MPIO_Host_Utilities_K 6.0.0.0         USR         DEINSTALL   SUCCESS

Ontap.MPIO_Host_Utilities_K 6.0.0.0         USR         DEINSTALL   SUCCESS

Ontap.MPIO_Host_Utilities_K 6.0.0.0         USR         DEINSTALL   SUCCESS

Ontap.MPIO_Host_Utilities_K 6.0.0.0         USR         DEINSTALL   SUCCESS

Ontap.SAN_toolkit.sanlun   6.0.0.0         USR         DEINSTALL   SUCCESS

Ontap.SAN_toolkit.scripts   6.0.0.0         USR         DEINSTALL   SUCCESS

        • 7 - Reboot (with single path)
        • 8 - Remove all other devices except boot LUN
        • 9 - Install all packages NetApp HUK (successful)

Installation Summary

--------------------

Name                       Level           Part        Event       Result

-----------------------------------------------------------------------------

NetApp.MPIO_Host_Utilities_ 6.0.0.0         USR         APPLY       SUCCESS

NetApp.MPIO_Host_Utilities_ 6.0.0.0         USR         APPLY       SUCCESS

NetApp.MPIO_Host_Utilities_ 6.0.0.0         USR         APPLY       SUCCESS

NetApp.MPIO_Host_Utilities_ 6.0.0.0         USR         APPLY       SUCCESS

        • 10 - Reboot (with single path)
        • 11 – Result: Error 554 on boot.
        •  
      • Test #2: Uninstalled of IBM N-Series HUK & Re-install of N-Series HUK.
        • Same steps as in Test #1.
        • Exception: Replace Step 9 with the following:
          • 9 – Re-install IBM N-Series HUK
  1. MPIO_Host_Utilities_Kit.config
  2. 0.0.0 COMMITTED  Data ONTAP MPIO PCM Host
  3. MPIO_Host_Utilities_Kit.fcp
  4. 0.0.0 COMMITTED  Data ONTAP MPIO PCM Host
  5. MPIO_Host_Utilities_Kit.iscsi
  6. 0.0.0 COMMITTED  Data ONTAP MPIO PCM Host
  7. MPIO_Host_Utilities_Kit.pcmodm
  8. 0.0.0 COMMITTED  Data ONTAP MPIO PCM Host
            • 10 – Reboot
  • 11 – Result: Reboot Successful.

 

          •  
  • Test Environment #2:
    • Purpose:
      • Uninstall IBM N-Series HUK in favor of NetApp 6.0 HUK
      • (Using AIX image based on NetApp N-Series)
    • Host/LPAR:
      • AIX 6.1 TL8 SP3
      • IBM N-Series HUK Installed.
      • Using NPIV not vSCSI via VIO Server
    • Storage:
      • SAN Boot LUN Data has already been migrated from N-Series to the following:
        • SAN Boot LUN on NetApp 7-Mode 8.1.4P1 (3140 HA pair)
    • Attempted Tests:
      • Test #1:  Install Native AIX MPIO Drivers on New AIX OS
          • Packages Installed:
          • Native AIX MPIO
            • NetApp 6.0 SAN Tool Kit
          • AIX OS:
            • New AIX OS Install from scratch
  • Results:
  • Reboot Successful.

 

        • Test #2a):  Install NetApp 6.0 HUK on New AIX OS
            • Packages Installed:
              • NetApp 6.0 HUK (All packages)
              • NetApp 6.0 SAN Tool Kit
            • AIX OS:
              • New AIX OS Install from scratch
        • Results:
        • Reboot Failed.
        • Test #2b):  Install NetApp 5.0 HUK on New AIX OS
            • Packages Installed:
              • NetApp 5.0 HUK (All packages)
              • NetApp 5.0 SAN Tool Kit
            • AIX OS:
              • New AIX OS Install from scratch
        • Results:
        • Reboot Failed.
  • Test #3:  Use a different AIX OS
  • Packages Installed:

 

            • NetApp 6.0 HUK (All packages)
            • NetApp 6.0 SAN Tool Kit
          • AIX OS:
          • Different AIX image
  • Results:
  • Reboot Failed.
  • Test #4:  Install *only* 3 packages from NetApp 6.0 HUK on New AIX OS
      • Packages Installed:
        • NetApp 6.0 HUK
            • Packages Installed:
              • 6.0.0.0  NetApp MPIO PCM Host Utilities Kit PCM Friend ODM Stanzas
              • 6.0.0.0  NetApp MPIO PCM Host Utilities Kit Path Config Tool
              • 6.0.0.0  NetApp MPIO PCM Host Utilities Kit iSCSI Disk ODM Stanzas
        • Package *NOT* Installed:
        • 6.0.0.0  NetApp MPIO PCM Host Utilities Kit FCP Disk ODM Stanzas
        • NetApp 6.0 SAN Tool Kit on new AIX OS Install from scratch.
      • AIX OS:
        • New AIX OS Install from scratch
  • Results:
  • Reboot Successful

 

 

 

I am wondering if anybody has come through similar situation and resolved it to boot from cDOT storage using AIX HUK 6.0

1 REPLY 1

johnh703

I have a customer having the same problem but they are using the NetApp HUK 6.0.0. No solution as thiis point.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public