Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

ONTAP Discussions

Can't Change Password for MetroCluster-TieBreaker


Hi all, I have an unusual problem.  I need to change the password for TieBreaker, but after following the Admin guide, I realized that the "&" in our password is causing issues with encrypting.


The problem I'm running into is when I put our password in the "<password>secret</password>" entry, which is in the format of "xxxxxxxx!!&", and then try to restart the service, I get this:


[root@ednastr02 MetroCluster-TieBreaker]# ./mctb_dfm.sh start


MetroCluster TieBreaker startup failed.

See logs for details.


The logs are telling me this:


2015-03-12 12:05:20,280 [main] FATAL com.netapp.rre.anegada.Main - Configuration Error: Configuration Exception:ParseError at [row,col]:[15,29]

Message: The entity name must immediately follow the '&' in the entity reference.

2015-03-12 12:05:20,284 [main] WARN com.netapp.rre.bautils.DfmCommand - DFM_EVENT MetroCluster-TieBreaker:Configuration-Error:Configuration-Failed, source: 1: Invalid configuration, vFiler DR TieBreaker cannot start. See log for details.


I went back and put a password without an "&" and it worked. I have also tried the various combinations to get it to accept it, but to no avail:



" Xxxxxx11!!&"

' Xxxxxx11!!&'

" Xxxxxx11!!\&"

' Xxxxxx11!!\&'


I leanred that the above is not the appropriate syntax to excape an XML &, so I tried the following:






But these all caused the service to fail starting up.  However, I did get the service to start up with this:




And it did encrypt, but the login is still failing.  So, I was wondering if this is throwing off the real password.  Anyone know if "&" is supported for this?  Thanks.



NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner