ONTAP Discussions

Confused about "partner" argument in ifgrp and vlan

Thomas_Schmidt
1,892 Views

Hi there,

 

I'm not quite sure if my HA configuration is correct and all interfaces will come up on HA partner in case of failover (now it's a bit to late for testing ...).

 

I have no IP configured on the ifgrp, so do I have to set

 

ifconfig ifgrp10GBE partner ifgrp10GBE

 

or doesn't it matter because it is configured on the vlan interfaces?

 

Do I have to use the interface name or the partner IP-Address?

 

Wrong?             ifconfig ifgrp01-80 192.168.9.20 netmask 255.255.255.0 partner 192.168.9.22

Right?               ifconfig ifgrp01-2 172.28.10.34 netmask 255.255.0.0 partner ifgrp01-2

 

Config is the following:

 

Node1:

hostname MN-Array-04
ifgrp create multi ifgrp01 e0a e0c
ifgrp create single ifgrp10GBE e1a e1b
ifgrp favor e1a
vlan create ifgrp01 80
vlan add ifgrp01 2
vlan add ifgrp01 70
vlan add ifgrp01 120
vlan add ifgrp01 110
vlan create ifgrp10GBE 4008
vlan add ifgrp10GBE 88
ifconfig ifgrp01-80 192.168.9.20 netmask 255.255.255.0 partner 192.168.9.22
ifconfig ifgrp01-2 172.28.10.34 netmask 255.255.0.0 partner ifgrp01-2
ifconfig ifgrp01-70 `hostname`-ifgrp01-70 netmask 255.255.255.0 partner ifgrp01-70 mtusize 1500 trusted -wins up
ifconfig ifgrp01-120 172.26.10.34 netmask 255.255.255.0
ifconfig ifgrp10GBE-4008 `hostname`-ifgrp10GBE-4008 netmask 255.255.255.0 mtusize 1500 trusted -wins up
ifconfig ifgrp10GBE-88 `hostname`-ifgrp10GBE-88 netmask 255.255.255.0 mtusize 1500 trusted wins up
route add default 192.168.9.250 1
vfiler run sn-nas-04 route add default 172.28.10.250 1
vfiler run an-nas-04 route add default 172.26.10.250 1
routed on
options dns.domainname metronet.lg
options dns.enable on
options nis.enable off
savecore

 

Node2:

hostname MN-Array-05
ifgrp create multi ifgrp01 e0a e0c
ifgrp create single ifgrp10GBE e1a e1b
ifgrp favor e1a
vlan create ifgrp01 80
vlan add ifgrp01 2
vlan add ifgrp01 70
vlan add ifgrp01 120
vlan add ifgrp01 110
vlan create ifgrp10GBE 88
vlan add ifgrp10GBE 4008
ifconfig ifgrp01-80 192.168.9.22 netmask 255.255.255.0 partner 192.168.9.20
ifconfig ifgrp01-2 172.28.10.35 netmask 255.255.0.0 partner ifgrp01-2
ifconfig ifgrp01-70 `hostname`-ifgrp01-70 netmask 255.255.255.0 partner ifgrp01-70 mtusize 1500 trusted wins up
ifconfig ifgrp01-120 172.26.10.35 netmask 255.255.255.0 partner ifgrp01-120
ifconfig ifgrp01-110 172.27.10.35 netmask 255.255.255.0 partner ifgrp01-110
ifconfig ifgrp10GBE-4008 partner ifgrp10GBE-4008 mtusize 1500 trusted wins down
ifconfig ifgrp10GBE-88 `hostname`-ifgrp10GBE-88 netmask 255.255.255.0 mtusize 1500 trusted wins up
route add default 192.168.9.250 1
vfiler run sn-nas-05 route add default 172.28.10.250 1
vfiler run an-nas-05 route add default 172.26.10.250 1
vfiler run kn-nas-05 route add default 172.27.10.250 1
routed on
options dns.domainname metronet.lg
options dns.enable on
options nis.enable off
savecore

1 REPLY 1

YIshikawa
1,846 Views
As you supposed, "ifconfig ifgrp10GBE partner ifgrp10GBE" is not needed.
You should use interface name rather than host name or IP address for partner option.
Public