ONTAP Discussions

Harvest is failing to send the metrics to remote graphite server

nvidia-india
views-count 1289 Views

We are having a standalone harvest installation which collects metrics from all filers/clusters. Since the number of storage to monitor is more, we are setting up pollers on remote site which sends data to US graphite server. All the modules are confired on the poller but its not sending any data to graphite server. Below is the error from the log from poller host

 

[2018-08-06 09:45:00] [WARNING] [cifs] Metrics NOT sent to Graphite. Cannot establish/maintain a connection to [harvest-server:2003/tcp]: Invalid argument
[2018-08-06 09:45:00] [WARNING] [cifs_stats] Metrics NOT sent to Graphite. Cannot establish/maintain a connection to [harvest-server:2003/tcp]: Invalid argument
[2018-08-06 09:45:01] [WARNING] [disk] Metrics NOT sent to Graphite. Cannot establish/maintain a connection to [harvest-server:2003/tcp]: Invalid argument
[2018-08-06 09:45:01] [WARNING] [hostadapter] Metrics NOT sent to Graphite. Cannot establish/maintain a connection to [harvest-server:2003/tcp]: Invalid argument
[2018-08-06 09:45:02] [WARNING] [ifnet] Metrics NOT sent to Graphite. Cannot establish/maintain a connection to [harvest-server:2003/tcp]: Invalid argument
[2018-08-06 09:45:02] [WARNING] [nfsv3] Metrics NOT sent to Graphite. Cannot establish/maintain a connection to [harvest-server:2003/tcp]: Invalid argument
[2018-08-06 09:45:02] [WARNING] [processor] Metrics NOT sent to Graphite. Cannot establish/maintain a connection to [harvest-server:2003/tcp]: Invalid argument
[2018-08-06 09:45:03] [WARNING] [system] Metrics NOT sent to Graphite. Cannot establish/maintain a connection to [harvest-server:2003/tcp]: Invalid argument
[2018-08-06 09:45:03] [WARNING] [volume] Metrics NOT sent to Graphite. Cannot establish/maintain a connection to [harvest-server:2003/tcp]: Invalid argument
[2018-08-06 09:45:03] [WARNING] [wafl] Metrics NOT sent to Graphite. Cannot establish/maintain a connection to [harvest-server:2003/tcp]: Invalid argument

 

 

Carbon/httpd is running on remote graphite server "harvest-server". No firewall is in place as i can telnet to "harvest-server" from the poller. Can someone assist on what could be the issue here?

 

thanks

 

2 REPLIES 2

Re: Harvest is failing to send the metrics to remote graphite server

J_curl
views-count 1290 Views

check the netapp-harvest.conf file.  Do you have the  "graphite_server" parameter set to "harvest-server:2003/tcp"?

 

Drop the ":2003/tcp", only specify hostname or IP. 

 

 

View solution in original post

Re: Harvest is failing to send the metrics to remote graphite server

nvidia-india
views-count 1290 Views

Thank you for helping identify the issue. Its fixed now. 

G2 Review Banner
All Community Forums
Public