ONTAP Discussions

How to create Root aggregate across external shelf during initialization

YUGO-S

Hi everyone,
First time posting here.

On a new FAS2720(9.5P5) and DS212C, I would like to configure ADP using a total of 24 NL-SAS disks.
So, I actually executed the steps 9a and 9b from the boot menu, but a Kernel Panic occurred after executing step 9b.
When a Kernel Panic occured, the following message was displayed.

------------------------------------------------------------------------------------------------------------------------------------
Jun 27 17:48:57 [localhost: raid.autoPart.start: notice]: System has started auto-partitioning 6 disks.
Jun 27 17:48:58 [localhost: raid.autoPart.done: notice]: Successfully auto-partitioned 6 of 6 disks.
Unable to create root aggregate: 5 disks specified, but at least 7 disks are required for raid_tec
------------------------------------------------------------------------------------------------------------------------------------

According to HWU, FAS2720 can configure ADP with 24 disks.
Is this due to a bug in the product? Or is there any problem with the procedure?

As a side note, I think that it is a problem that occurs only when an external shelf is connected,
because there is no problem in performing the same procedure without connecting DS212C.

 

Could you please help?
Many thanks

23 REPLIES 23

YUGO-S

TMAC CTG,

Sorry for late reply.

 

I tried it as you taught, but still it did not work well.
I will attach a log when I perform the initialization, can you give me some advice?

TMAC_CTG

Specifically, this line from the node 1 log file

 

AdpInit: Root will be created with 6 disks with configuration as (2d+3p+1s) using disks of type (FSAS).

That should be Raid-dp for root 

TMAC_CTG

Well, that was enlightening. Thanks for the logs.

 

I think your best bet right now is to actually open a case. I suspect you are hitting a bug as those directions should have worked as expected.

 

I'm still looking around, but since I'm on vacation I'm not looking to hard until I get back to a PC many hours from now.

 

Please post what becomes of this.

 

There is likely another special environment variable needing to be set (which in my opinion should not have to be as a system default). The HWU clearly indicates what you are doing should work AND it should be using RAID-DP for the root aggregates only.

 

That is why I believe what you're seeing is a bug.

 

Please let us know!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public