ONTAP Discussions

How to quit an SSH session by typing 'exit'?

iancampbell123

Hi folks,

This is sort of a minor issue, but annoying nonetheless since to close an SSH session, you must press CTRL-D, then close the Putty exit dialog, then close the actual Putty window itself. How can I configure a filer to quit an SSH session by just typing 'exit' at the prompt?

Two of my filers already exhibit this behaviour (both clustered 3240's), and two don't, so somewhere along the line I must have made some configuration change that enabled this behaviour, but I'm not sure what. Secureadmin is enabled on all allowing SSH and SSL. The two 3240's are running 8.01, but the configuration was migrated from a couple of 3020's running ~7.3 where it also worked that way, so I don't think it is filer or ONTAP version-specific.

Any body have an idea? My searches are not turning up anything... Thanks for the help,

ianc

1 ACCEPTED SOLUTION

aborzenkov

Compare option telnet.distinct.enable on filers where it works differently ... is it different?

View solution in original post

8 REPLIES 8

dougsiggins

I noticed this as well. Check the versions on the filer(s) on 8.0 (and GX) and upwards you could type exit (or ctrl-d works as well). On earlier versions 7.2 and 7.3 you had to hit ctrl-d.

No, it's not ONTAP specific.

The two 3240's are at 8.0.2 in 7-mode, but again, they were able to terminate on exit when running 7.3.2.

The two filers requiring CTRL-D are running at 7.3.2 and 8.0.1P5 in 7-mode.

ianc

aborzenkov

It depends on telnet.distinct.enable setting. Older versions defaulted to off, newer versions default to on.

TOPHAN

Thank you very much!!

aborzenkov

May be you have different PuTTY configurations for different filers? PuTTY can be configured to skip confirmation in this case.

iancampbell123

Nope, I don't keep separate Putty configurations for each filer; just type in the name when I want to connect.

On the two 3240's, I just type in 'exit' and session terminates immediately. On the other two filers, I type 'exit', and the filer then responds with 'Use control-D to exit'...

Thanks for the response though!

ianc

aborzenkov

Compare option telnet.distinct.enable on filers where it works differently ... is it different?

View solution in original post

iancampbell123

You are a genius! Thanks very much!

I checked the two filers which required CTRL-D and this option was set to 'off', whereas on the others it was set to 'on'. I changed it, logged off, then back on again and now they will both gracefully terminate a session by just typing 'exit'.

Thanks very much; this has been annoying me for quite some time now. I appreciate it!

ianc

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public