ONTAP Discussions

NDMP restore of 7-Mode NetApp LUN on Cluster mode - LUN not appearing

Hi Folk,
(not sure if this is the right forum, please move or advise if needed!)
We've historically been backing up data from our old 7-Mode NetApp using NDMP into CommVault, including volumes containing LUNs.  (don't ask, before my time!)
They were originally written to tape, that have now been migrated to Cloud (Azure) storage. (We do have the tapes available for a limited time)
However, now we've migrated to Clustered ONTAP, and we are trying to restore old 7-Mode LUNs to the new Cluster.
I have successfully restored them to an old 7-mode controller as a visible LUN, but we need to power it down and dispose of it.....
I have also restored the LUN file to cluster mode, but it does not appear as a NetApp LUN - it appears as a file (as NetApp LUNS are) but is lacking that something special that tells the Cluster/Node that it's a LUN.
I have tried restoring the LUN/file using node-scoped NDMP, SVM-scoped (both SVM direct and cluster-aware), but none of them appear as a LUN.
Am I missing something obvious?
We're on CommVault V11.20, CLuster is on NetApp ONTAP 9.7 P3  and the old filers were on 8.2 SP1


Since the LUN is from a 7mode system it will need to be updated so the Cluster mode system will recognize it . The command is "lun transition start -vserver VSERVER -volume VOLUME_NAME".  Be very careful when transitioning using commands to transition LUNs that have been moved around. If they have been corrupted mounting them to a Cluster mode system could cause a panic and boot loop.  Use the "lun transition 7-mode show" command to get detailed information about the restored LUN. If it does not recognize the file as a 7mode LUN I would not continue. Below is a link to the lun transition commands.


lun transition commands




You Sir, are a legend!


I shall tread very carefully with it though.... really don't want a panic! (especially as our Windows iSCSI clients aren't set up with multipathing yet 😞 )


We'll see how long support takes to get to this.


Except my restored LUN files aren't recognised by lun transition....


I can *see* the file if I drop into node run;

dc2st02*> ls -l /vol/restore_temp/exchsnap__vwexch03__recent
d777 12586 2 4096 Mon Oct 12 18:20:12 AEDT 2020 .
d755 64 3 4096 Mon Oct 12 18:20:12 AEDT 2020 ..
10600 12587 1 21484431360 Fri Sep 16 21:31:53 AEST 2016 db09_lun

but  it doesn't recognise it ;

dc2st::*> lun transition 7-mode show -vserver dc2svm2 -path /vol/restore_temp/exchsnap__vwexch03__recent/db09_lun
There are no entries matching your query.




Hello OzStu,


You cannot migrate a 7-mode LUN via copying the ".LUN" file to a Clustered ONTAP system. This only worked between LUNs on 7-mode. As previously mentioned, there are numerous differences between a 7-mode LUN compared to a Clustered ONTAP LUN, i.e. Cluster ownership, VSERVER\SVM ownership, various Cluster Database entries. Clustered ONTAP can't simply import the LUN since all this is missing in a 7-mode LUN.


You must use one of two methods to properly migrate a LUN from 7-mode to Clustered ONTAP: 7-mode Transition Tool or SnapMirror based copy. Please see the following guide for more details: 


7-Mode Transition Tool 3.2 SAN Host Transition and Remediation Guide 





Team NetApp

Team NetApp


So how do we restore old 7-mode LUNs when we only have Cluster?  Are you telling us we have to keep a 7-mode controller running indefinitely?  


Unfortunately this didn't fix the issue 😢

See my other reply, but the 'show' command didn't return anything.


Interestingly, in the document at:


on page 46 it specifically says;


Restoring a 7-Mode volume to an ONTAP volume


  • A 7-Mode LUN is restored as a LUN on an ONTAP volume.
  • You should retain the ONTAP LUN identifiers when restoring a 7-Mode LUN to an existing ONTAP LUN.

(not sure how you can know the LUN Identifier from a 4yo backup though)


I also tried restoring over the top of a LUN I had just created - it failed abysmally with both the restore from CommVault failing, and the LUN getting ruined as well.  I had to delete the containing volume to get rid of the LUN.


For restoring over the LUN, COmmVault reported errors;

NDMP Server [abcd.abcd.gov.au] reported the following error: [RESTORE: Error: write error extracting inode 96, name <name unknown>: File too large].

NDMP Server [abcd.abcd.gov.au] reported the following error: [DATA: Operation terminated: EVENT: INTERNAL ERROR (for restore_temp)].

Failed to get the configuration for application type [13], operation type [5], phase [0].




I have tried restoring to a Qtree, and restoring to the root of the volume with no luck.  I have even gone back to the Tape Backup itself (while we still have them - they're due to be securely shredded) and still wasn't able to get ONTAP to recognise it.


Hi OzStu,


Yes, the dump engine can restore a LUN, but there are other caveats involved that will impact whether the backup & restore are successful. Mainly both the host OS and application(s) are required to be properly quiesced prior to initiating the backup. 


Since you are only attempting to access a copy of the data, meaning the data also lives in a backup; you can attempt the following unsupported procedure. The below procedure will create a malformed Clustered ONTAP LUN as previously mentioned, a 7-mode LUN has missing attributes and parameters that exist in Clustered ONTAP.


1. Create a backup of your Cluster configuration and copy the backup off the NetApp system, (HTTP server required for restoration)

::> system configuration backup create

2. Copy the 7-mode .LUN file you want to the Clustered ONTAP volume

3. Use the following command and complete the syntax on the copied 7-mode .LUN file:

::> lun create -file-path <file-path>

4. Perform OS & application health check 


 Again, the above is an unsupported procedure.


The other Supported method besides using 7-MTT would be to restore the entire contents of the LUN to anything visible to the NetApp Cluster and perform a Foreign Lun Import.





Team NetApp

Team NetApp


Hmm interesting!


I'm assuming we need to specify the specify the full gamut of parameters such as vserver and size?  (How do we know what size to specify - does it have to be exact?)


How potentially catastrophic is this?(eg should I  be doing it on a weekend in a change window?)




Thank  you 🙂 


OK, I finally got to try this on a 9.7 simulator, but it returned the error:


Error: command failed: File exists




I wonder when there'll be a 9.8 simulator?


Well, I've spun up a simulator of 9.5.6, and I am able to restore a 7-mode LUN successfully, and it pops up in System Manager within a minute or so.  


I can then map it to a Windows server and mount it and access the data thereon.


Gonna try a 9.7 simulator next....


Well, I tried the 9.7 simulator, but no luck.  The LUN does not appear, and none of the LUN Transition commands have any affect either.


Going to try the unsupported LUN create option now....