ONTAP Discussions

Single-Node Cluster damage

FLISCHEIDBRACHT
8,122 Views

Hi,

my Cluster don't start up.

 

***********************
** SYSTEM MESSAGES **
***********************

Internal error: Cannot open corrupt replicated database. Automatic recovery
attempt has failed or is disabled. Check the event logs for details. This node
is not fully operational.

 

 

vifmgr Database seem to be broken.

Is the any option to repair ist?

 

When i change to 7-Mode shell on the Node i can see all data-volumes are ok.

The Cluster is a Single-Node System.  Another options is to reinstall the Cluster and bring back the volumes later.

When i start cluster setup and configure it, after finih the error will be the same.

 

Any ideas?

Running Ontap 9.6P5

 

1 ACCEPTED SOLUTION

shuklas
7,913 Views

::> system configuration recovery node mroot-state clear -recovery-state

Options for recovery-state are 'all|wafl|rdb'

 

The command will only available when there is an issue .

View solution in original post

11 REPLIES 11

SpindleNinja
8,115 Views

try this: 

 

halt the node to get to the LOADERA> 

 

run:  "unsetenv bootarg.init.boot_recovery" 

and then "boot_ontap"   

 

FLISCHEIDBRACHT
8,108 Views

LOADER-A> unsetenv bootarg.init.boot_recovery
Could not delete environment variable 'bootarg.init.boot_recovery': Environment variable not found
Environment variable not found (errcode=-9)

 

 

i have read in a other forum that this option is not longer supportet in 9.6


SpindleNinja
8,104 Views

huh  TodayILearned... 

let me do some additional looking. 

 

 

SpindleNinja
8,054 Views

Nothing else I can find, and i've checked with a few others.  I'd open a case asap if you haven't already. 

FLISCHEIDBRACHT
8,023 Views

Thanks for your Support.

shuklas
7,932 Views

Not sure if this is fixed or not, In 9.6 we have a command to verify and fix this from cluster shell 

 

system configuration recovery node mroot-state show << This will show the state of RDB 

based on the output you can use the clear command to fix that .

 

 

SpindleNinja
7,915 Views

What's the clear command?  I don't see it in the command 

 

labcluster::*> system configuration recovery node mroot-state ?
show *Show mroot recovery state

shuklas
7,914 Views

::> system configuration recovery node mroot-state clear -recovery-state

Options for recovery-state are 'all|wafl|rdb'

 

The command will only available when there is an issue .

SpindleNinja
7,911 Views

Cool, thank you for the info. 

 

Randy_Lin
5,569 Views

Thank you , shuklas 🙂

 

I tried these steps and the problem is solved.

::> set -priv diag

::*> system configuration recovery node mroot-state clear -recovery-state rdb

::*> reboot

 

vipingupta
5,458 Views

very useful command 

 

issue resolved with below command 

 

set -priv diag

system configuration recovery node mroot-state show
system configuration recovery node mroot-state clear all

 

Thanks 

Public