ONTAP Discussions

SnapProtect 10: SMTape full / incremental / differential tape copies


Hi dataprotection community,

I'm playing with SnapProtect 10 SP5b and SMTape (image saveset) backup copies to tape (from ONTAP 8.1.4P1 7-mode controllers to an LTO4 tape library).

Snapshots and SMtape backups work like a charm, more or less out of the box, and performance is really nice - so this looks like a promising solution for a customer request.

I can successfully create full, incremental and differential tape copies using the smtape feature. Nice.

However, I'm not able to do SMTape incremental restores.

E.g. as a simple test:

I create an empty volume "/vol/restoretest", and do a "vol restrict restoretest" on the Netapp controller.

Now I do a full restore (with copy precedence set to "2" - redirected to my test volume, a "dr test restore from tape") of a previous succesful full backup.

This steps works without errors, and as a result I have my original volume contents within my "restoretest" volume, including all snapshots. Nice.

Then I want to restore the first incremental on top. The job starts, but quickly fails with an error message on the netapp controller and also in Snapprotect.

The message log on the filer shows:

Sat Mar 29 15:39:55 CET [xxx:smtape.restore.fail:error]: SMTape restore to restoretest from tape failed.

Sat Mar 29 15:39:55 CET [xxx:smtape.restore.err:error]: Restore from 'NDMP_REMOTE_005507' to '/vol/restoretest' failed: SMTAPE: Cannot Init Input, aborting.

Looking at the Netapp smtape documentation, it states that the first full smtape restore ("initialize") must not be "broken off" before restoring further incrementals.

However, as soon as my first snapprotect full restore finishes, my volume shows "broken off" in snapmirror status.

So SnapProtect breaks the smtape relationship automatically without asking me

I have found no setting within the UI, nor an "advanced registry setting" to control this behaviour.

I have also tried to restore (to a newly created and restricted empty test volume) directly from the incremental copy (so not browsing the full backup, but the incremental as the first step), and hoped that snapprotect would automagically restore the full first, then do the incremental... Nope, this also fails (same error), the full is not even tried, and the incrmentals fails (as expected)...

Has anyone else tried smtape incremental or differential restores using snapprotect? Did anybody have success with it?

Is there a setting / option which I'm overlooking?

Thankful for any hints.



Re: SnapProtect 10: SMTape full / incremental / differential tape copies


I found it out myself. When I right-click the subclient, then select "Browse and Restore" (instead of "view backup history" and then "browse and restore" on a specific backup version), then I can choose a given time, and this way Snapprotect restores all the needed SMTape full plus incrementals - it automatically keeps the snapmirror chain intact and finally breaks the mirror after the last needed incremental restore.

So it was a layer-8 problem (though the UI is a bit misleading...)

View solution in original post

G2 Review Banner
All Community Forums