ONTAP Discussions

Unable to assign disk ownership after NVRAM card swap.


Hi there,


I recently had to have the NVRAM card replaced by a TPM due to a failure preventing the system from booting.  After the card was replaced we did not run any procedure to modify boot args or system options, the documentation for the procedure does not mention this as a requirement -- I hope that is correct.


Now that the system boots again with the new card installed, I am trying to decommission the SAN disks, so I have entered the Ctrl+C menu -> option 5 -> Maintenance Mode.


From maintenance mode it seems the filer has taken on a new system id, as I believe the system id is stored in the NVRAM card, as a result it believes the disks are owned by another NetApp as the disk reversations feature the old system id.  I am completely unable to assign the disks to the new system id.  The below is what I've tried so far.


* System is a V6040 V-Series.

* Ontap version is 8.1.4 7-mode, do you thinking upgrading to 8.2.5 will cure this?

* I ultimately need to remove ownership on the disks, so I can clear the SCSI reservation and then decommission the disks on the SAN.  I can't do this on the SAN until the SCSI reservation is cleared, is there any other method of doing this?  Either via the "systemconsole" or externally to the NetApp by presenting the disks to another host?  I've tried the Symantec windows tool for clearing SCSI reservations but it won't allow me to do it on a host which isn't a member of the cluster.


Local System ID: 118058425


If I run disk assign, it complains the disks are owned by the old system ID of 118071405 and will not assign ownership:


*> disk assign all -f

disk assign: Disk assigned but unable to obtain owner name.  Re-run 'disk assign' with -o option to specify name.

disk assign: Assign failed for one or more disks in the disk list.

*> May 21 13:31:47 [localhost:diskown.StealingDiskPrevented:warning]: Ownership for disk ukdxssw016:7-5.105L14 (S/N 50 131BC4042) cannot be changed because system ?? (ID 118071405) currently owns the persistent reservation.


If I run disk reassign the system complains it can’t find any disks:


*> disk reassign -s 118071405 -d 0118058425

Disk ownership will be updated on all disks previously belonging to Filer with sysid 118071405.

Do you want to continue (y/n)? y

May 21 13:32:26 [localhost:diskown.ReassignFailed:warning]: Disk reassign request failed. Reason: No disks found.

Unable to complete disk reassign successfully.(Status : 13150)


If I try to force disk assignment individually I get the following error:


*> disk assign ukdxssw015:7-5.107L323 -f

disk assign: Disk assigned but unable to obtain owner name.  Re-run 'disk assign' with -o option to specify name.


I can’t use the –o option because there is no recorded owner of the disks in the output of disk show –v but clearly this contradicts the output of disk assign all shown earlier, where it lists they are owned by ?? (ID : 118071405)


*> disk show -v


Local System ID: 118058425


  DISK       OWNER                  POOL   SERIAL NUMBER           HOME                     CHKSUM

------------ -------------          -----  -------------           -------------            ------

ukdxssw016:7-5.105L14 Not Owned                       NONE  50 131BC4042         Block


If I use disk remove_ownership I get an error 27 for each disk:


*> disk remove_ownership all -f

All disks will have their ownership information removed.

For high availability (HA) configurations, the partner node must be down.

May 21 13:38:31 [localhost:diskown.ownerChangeFailed:error]: Disk ownership change request failed on disk ukdxssw016:7-5.105L14 (S/N 50 131BC4042). Status: 27.



If you can offer any advice on the above that would be appreciated.



@jamcguire wrote:

I ultimately need to remove ownership on the disks.

According to output you provided you have single unowned disk, so I'm not sure I understand your question.


I have in excess of 140 disks but I've truncated the output, they have a SCSI reservation on them so I can't remove them from the back-end SAN.


If you look at my original post, one command shows the reservation and ownership belonging to sysid xyz, another command shows unowned.  Any command I try will not assign or remove ownership of the disks, _that_'s the problem.  I want to assign ownership and then remove_ownership.


I'm wondering if I get into the systemshell can I use camcontrol to remove the reservation?


Any suggestions please?