ONTAP Discussions

Unable to change file owner on CIFS share in OnTAP 9 SVM


We're currently (finally...) making a switch from EMC to NetApp, and our brand new Boxes are running on ONTAP 9 🙂

but we have a weird problem, currently blocking our cifs migration...


when using a cifs share on a svm hosted on one of our new FAS 2554 (which were delivered with ontap 8.3 and upgraded to 9 before any configuration) we cannot set the owner of a file or folder to any other user.

I can surely TAKE ownership of a file with my admin account, but I cannot set owner to some other user account... something we require for the migration of our terminal server profiles.


oddly enough, when creating a cifs svm and shares on our - also new - AFF 8040, which was delivered preinstalled with ontap 9, everything works fine.

our netapp consultant also was kind of clueless about that and couldn't reproduce this issue in his testlab, so we opened a case.


but maybe someone of the community knows what's going on 🙂

either way, I'll post the solution once the case is closed.



as for the exact error message that occurs when trying to set file/folder owner on a FAS 2554 cifs share:

The security ID may not be assigned as the owner of this object



Issue was resolved after upgrading to ONTAP 9 RC2. We closed the case!


View solution in original post



Same issue on Ontap 9.4 - so whats the deal?


We have this exact same issue on cDOT 9.5P2...

Hi Steve,

Did you adding that group to build in Administrator group and then trying to change ownership on the share ?

I am sure this will work.


No that didn't work, we tried that.

Neither using groups, nor specific user accounts.

We also tried setting the privilege flags to no avail.


We guessed it was some kind of hidden option in the vserver or wafl, but we won't find out now since it works after upgrading to RC2.


Thanks for your response, I tried adding to buildin Admin group and it worked. 

Hi steve,

We have similar issue on ontap 8.3.2 version on Fas8040 model system.

So upgrade to 9 rc 2 fixes this issue is it ?


Issue was resolved after upgrading to ONTAP 9 RC2. We closed the case!


View solution in original post


Did you by chance ever get a BUG or KB or anything from NetApp to explain why it was fixed in upgrade?


No... after the issue was resolved with the upgrade, the case was closed.

Meanwhile we are on 9.1 RC1 and didn't encounter this anymore.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner