ONTAP Discussions

hidden extended NTFS attribute:how to remove?




we moved our Profiles, Users & Group CIFS shares from a Netapp MetroCluster to a Windows Storage Server Cluster (don't ask why, management decision).

everything is working fine so far, but now we want to archive unused files using CommVault Simpana. It works with newly created files but fails with files copied from Netapp.

after a lot of testing we found out that the problem is a hidden extended attribut called ".NETAPP". we tried to copy the files to different location in the hopes that the copy will forget about the attribute but magically the hidden attribute follows the file where ever it goes.

the only tool so far the can display this attribute is "FileTest". In the GUI I can remove the attribute but when I try the commit the change I get permission denied even with Domain Admin privileges.


I know this is not exactly a Netapp issue but the name of the attribute suggests that Netapp was involved. does anybody have an idea how to remove this attribute from the files? BTW: there are 10 million files to be archived, so a manual solution is interesting but probably would take months to implement.


Thanks for your feedback





Yes, blame your management


thanks for the moral support



Hi - did you ever find a fix for this?  We have a very similar problem!






No fix, just a work-a-round.
We copied the data to ReFS which doesn’t support extended attributes. This effectively removed the flag. Then we copied the files back to their original place. After that CommVault was able to archive the files.
It would probably also work with FAT32 but we were afraid of file-system-limitations, so we decided to go for ReFS.


Hope this helps


Thanks for the update Boomer.  We'd been given a workaround of compressing and uncompressing to remove the attribute but with we have about 8Tb of data to copy so I will retire before it finishes, and I'm only 39 Smiley LOL 


I have the same problem.


DeDup on Windows Server 2012 (R2) is not running with files which I copied using robocopy from a netapp CIFS share.

To be exact, this EA stream is not on all netapp saved files attached, maybe on 50% of all files. Copy to REFS and back to NTFS is the only workaround I have so far...




Veritas has published the EVEARemovalUtility to accomplish this very task as their archival solution suffers from the incompatibility between EAs and junction points they are creating as pointers to archived data. The tool is a free download, usage is straightforward:

  • EVEARemovalUtility.exe \\server\Share -d -s to create a list of files with their respective extended attributes
  • EVEARemovalUtility.exe \\server\Share -r -s to strip all files of EAs

Probably due to its age, the way it is installed and lack of updated documentation, it does not run on Server 2012 R2 out of the box, complaining about missing DLLs. For my use case, I ran it on a Server 2008 R2 machine as a workaround.